Untitled Document

Bienvenue!

Bienvenue au tutoriel de conception de niveau de 3D GameStudio. Il contient une partie théorique et une partie pratique, toutes les deux réalisées par différents auteurs. C'est vous qui décidez avec lequel vous voulez commencer. Si vous voulez jouer immédiatement, allez à la partie pratique. Autrement, commencez ici.

Je pense que vous trouverez ce tutoriel différent de la plupart des autres. Ce n'est pas un tutoriel "pas à pas" pour construire le niveau de demo ou tout autre niveau. C'est une compilation de trucs, astuces et autres conseils utiles recueillis ensemble dans un endroit pour vous aider à concevoir vos propres niveaux. Vous passerz par les bases de chacune des choses, de faire lesrecherches à l'éclairage de votre niveau avec toutes ce qui se passe dans l'intervalle. Le tutoriel est structuré pour vous permettre de prendre votre temps pendant que vous apprenez différents aspects de conception en temps réel du niveau 3D. Aussi, asseyez-vous confortablement, détendez et, surtout, ayez du plaisir lorsque vous entrez dans le monde de la conception en temps réel du niveau 3D !

Traduction Alain Brégeon le 12/03/2004 alainbregeon@hotmail.com

allez à la partie 1.1 - L'espace de travail de WED

Tutoriel - Table des matières

Part 1 - WED
Part 1.1 - L'espace de travail de WED
Part 1.2 - Paramétrage des raccourcis
Part 1.3 - Travailler avec les vues de WED
Part 1.4 - Le système de grille de WED

Part 2 - Tracer et projeter
Part 2.1 - Le début
Part 2.2 - Décider du genre
Part 2.3 - Faire les recherches

Part 3 - Snap, Crackle and Pop
Part 3.1 - Utiliser l'aimant
Part 3.2 - Démarrer en douceur
Part 3.3 - Duplication
Part 3.4 - Rotatoig
Part 3.5 - Déplacer les sommets (Vertex), les bords (Edge) et les faces

Part 4 - Une image vaut mieux qu'un long discours
Part 4.1 - Plus grand ne veut pas dire meilleur
Part 4.2 - Utiliser le redimensionnement des textures
Part 4.3 - Assortir les couleurs de vos textures


 1 - Bienvenue!

Bienvenue au tutoriel de conception de niveau de 3D GameStudio.Je pense que vous trouverez ce cours d'instruction est différent de la plupart d'autres tutoriels. Ce n'est pas un guide d'instruction "pas à pas" pour établir le niveau de la demo ou tout autre niveau de cette matière. C'est une compilation des trucs et astuces et d'autres morceaux d'information utiles réunis ensemble dans un endroit pour vous aider à concevoir vos propres niveaux. Le cours d'instruction est structuré pour vous permettre de prendre votre temps pendant que vous apprenez différents aspects de conception en temps réel de niveaux 3D. Aussi, asseyez-vous confortablement, détendez-vous et, surtout, prenez du plaisir lorsque vous entrez dans le monde de la conception en temps réel de niveaux 3D !


 1.1 - La zone de travail de Wed

1.1 – Si vous avez parcouru la nombreuse documentation de 3D GameStudio et pratiqué les nombreux exemples en utilisant les différents outils mis à votre disposition, vous avez déjà des notions sur WED, l'éditeur de monde (Worl Editor) de 3D GameStudio. Avant d'entrer dans les coins et les recoins de la conception d'un niveau réel, je pense que c'est mieux de passer en revue un certain nombre de choses concernant WED qui vous rendront la vie plus facile lorsque vous commencerez le grand voyage pour donner vie à vos idées 3D. Lorsque vous installez pour la première fois 3D GameStudio sur votre ordinateur et que vous lancez WED vous devriez obtenir quelque chose qui ressemble à cela:

J'ai le sentiment que beaucoup de personnes laissent leurs applications avec leur paramétrage par défaut. Dans de nombreux cas, les compagnies qui développent ces applications font en sorte que les paramétrages par défaut s'adaptent au plus grand nombre. Néanmoins vous pouvez vouloir avoir un fonctionnement différent de votre WED. Tout ce qui concerne l'interface de WED peut être déplacé depuis la barre d'outils:

Vers la fenêtre de projet (Project Window):

Vers les vues elles-mêmes:

A propos des vues, vous pouvez même ajouter des vues en plus des 4 existantes que vous voyez lorsque vous démarrez WED:

Paramétrer l'espace de travail de WED pour qu'il s'adapte à votre façon de travailler est aussi important que de s'installer correctement et de bien positionner tous les éléments qui vous entourent comme le bureau, l'écran, le clavier, la souris etc. Une note à propos de la barre d'outils, bien que la barre d'outils soit déplaçable / replaçable, il est conseillé de la positionner en haut ou en bas seulemnt car sur les côtés elle reste à l'horizontal et occupe donc beaucoup de place. Si vous utilisez plusieurs écrans vous pouvez créer une grande zone de travail pour vos vues en déplaçant un maximim de choses sur un des autres écrans..


 1.2 – Paramètrage des raccourcis

Organiser votre zone de travail de WED rendra non seulement votre expérience de WED plus agréable, mais elle vous fera gagner beaucoup de temps à la longue. Mais il n'y a que vous pour le faire dans cette zone. Il y a une autre façon d'augmenter votre déroulement des opérations dans WED, c'est en installant des raccourcis pour vos actions les plus généralement utilisées. Il a été prouvé maintes et maintes fois que les gens qui utilisent des raccourcis clavier travailleront beaucoup plus rapidement qu'une personne qui n'en utilise pas. Cela prend certainement plus de temps de retirer votre main du clavier, de saisir la souris, de la déplacer vers un menu, de trouver et de choisir votre élément de menu, de cliquer dessus puis de placer votre main de nouveau sur le clavier, qu'il n'en faut pour laisser simplement votre main là où elle se trouve et pour appuyer sur les touches appropriées. Puisque WED nécessite que l'on utilise la souris et puisque je suis droitier j'ai paramétré un maximim de mes raccourcis clavier pour qu'ils puissent être utilisés avec ma main gauche. De cette façon ma main gauche s'occupe du clavier pendant que la droite s'occupe de la souris.

Pour accéder à la zone où vous pouvez changer vos raccourcis de WED allez dans le menu FILES et cliquez sur PREFERENCES. Une fenètre de dialogue apparaît avec plusieurs onglets. Cliquez sur l'onglet KEY:

Vous noterez que cette zone est divisée en 2 sections principales, une fenètre avec une liste des commandes sur la gauche et sur la droite des champs de saisie et des boutons. Sélectionnez un des items de la liste des commandes comme “Undo”. Vous voyez que le raccourci actuel s'affiche dans le champ "Current Shortcut " ce qui pour Undo est <Ctrl+Z>. Ce qui signifie qu'en pressant la touche (Ctrl) et la touche Z en même temps WED annulera votre dernière action.réalisée dans WED. Mais que faire si vous ne voulez pas utiliser cette combinaison de touches pour Undo?

Sous le champ "Current Shortcut" il y a un champ de saisie nommé "New Shortcut". Dans ce champ apparaît la même combinaison qu'il y a dans le champ "Current Shortcut". Si vous voulez changer le raccourci il vous suffit de vous positionner dans le champ "New Shortcut" de sélectionner le texte existant en le mettant en surbrillance et de taper la touche ou la combinaison de touches que vous souhaitez utiliser. Le champ "New Shortcut" affiche à présent ce que vous avez tapé. Une fois que vous avez ajouté ou modifié les raccourcis que vous souhaitez pour WED vous devez sauvegarder vos choix en cliquant sur le bouton "Save Shortcuts". A partir de là vous donnez un nom à vos raccourcis ce qui vous permet de sauvegarder différentes combinaisons et de les charger pour les utiliser en fonction de vos besoins.

Ca n'est quand même pas compliqué d'installer des raccourcis sur WED, n'est-ce pas? Alors n'hésitez pas à le faire. Si comme moi vous êtes droitier et que vous prévoyez de laisser votre main gauche sur le clavier et la droite sur la souris, vous ferez en sorte que les raccourcis soient facilement accessibles à partir de la main gauche. J'ai essayé de faire des raccourcis qui ne nécessitent pas de ma part de baisser les yeux sur le clavier. De cette façon je regarde en permanence mon travail et je ne suis pas distrait en détournant le regard. Avec un peu de recul et de pratique vous constaterez que vous développez réellement des niveaux dans WED plus rapidement qu'avant.


1.3 – Travailler avec les vues de WED

Si vous êtes assez nouveau dans la 3D en général alors les quatre vues dans WED peuvent vous sembler un peu étrange. Si c'est le cas, alors vous devrez jouer un peu avec WED avant d''essayer de travailler à n'importe quoi de sérieux. Après un moment vous trouverez les quatre vues indispensables au bon déroulement des opérations.

Les vues sont où toute l'action a lieu quand vous créez vos mondes 3D en temps réel. C'est dans ces vues que nous respirons la réalité dans nos rêves et les faisons venir à la vie de sorte que d'autres puissent les éprouver aussi. pour ce faire, nous devons apprendre à mieux les connaître.

Par défaut WED a ses quatre vues affichées comme ceci :

Chacune des quatre vues a son nom et c'est très utile. En haut à gauche la vue est étiquetée "Top" c'est à dire "dessus". Cette fenêtre fournit une vue de haut en bas à votre monde. Elle est essentielle pour lorsque vous devez éditer ou regarder quelque chose à partir du dessus, tel que le toit d'un bâtiment, par exemple. WED a une vue du dessus mais pas de vue du dessous. Par conséquent, vous devrez employer cette fenêtre pour éditer tout ce qui se trouve aussi bien en bas ou en dessous de votre monde.

La vue en bas à gauche est étiquetée "Back" c'est à dire "arrière" et c'est une fenêtre qui permet de voir votre monde 3D de dos. Évidemment vous employez cette vue pour éditer votre géométrie 3D du dos. Puisque WED n'a pas une vue de face vous éditerez également votre partie antérieure d'ici.

La fenêtre en bas à droite est étiquetée "Side" c'est à dire "côté". C'est donc une vue de votre monde 3D de côté et vous utiliserez cette vue pour éditer tout ce qui se passe de côté bien entendu, qu'il soit gauche ou droite).

Ces trois vues n'affichent pas votre monde comme vous le verriez dans le jeu. Tout ce qui est vu dans ces fenêtres sera orthogonal et dans le mode fil de fer. Orthogonal signifie que tout est visualisé parfaitement tout droit sans que la perspective ou la profondeur soit montrée du tout. Ceci signifie que si deux murs sont exactement de la même taille mais distant de plusieurs centaines de mètres, ils apparaîtront exactement de la même taille dans ces vues. Puisqu'elles sont montrées en tant que fils ceci peut vite devenir confondant quand votre niveau devient complexe, mais vous verrez que l'édition en mode fil de fer est importante.

La dernière vue qui se trouve en haut à droite est étiquetée 3D View c'est à dire "vue 3D". Cette vue vous montre votre monde 3D dans un mode perspective et vous pouvez choisir parmi 3 possibilités d'affichage pour voir la géométrie de votre niveau, fil de fer, solide ou texturée.

Le mode fil de fer (Wire frame) affiche votre monde comme sur les 3 autres vues mais en perspective 3D. J'utilise rarement ce mode,mais il peut être utile de temps en temps. Je pense qu'il peut être utile si vous avez un très grand niveau, ou une machine peu performante car l'affichage se fait très rapidement.

Le mode solide affiche votre niveau comme s'il était fait de solides mais qui seraient tous de la même couleur. Il est mieux que tous ces fils emmêlés surtout sur un niveau complexe mais l'uniformité de la couleur devient vite lassant et il est difficile de voir un détail en particulier. Comme le mode fil de fer, il peut-être utile lorsqu'il est nécessaire d'accélérer l'affichage car il est plus rapide que le mode texturé.

Il est fort probable que ce soit avec le mode texturé que vous travaillerez le plus. Il vous permet de voir votre niveau avec toutes ses textures et ses éclairages. Le mode texturé est plus lent lorsque vous déplacez la caméra, mais il donne une représentation plus proche de ce que sera votre niveau après compilation et exécution.

Même si les choses apparaîssent beaucoup mieux dans la vue 3D il est beaucoup plus difficile d'y faire l'édition. Vous pouvez choisir et déplacer des choses autour, mais il n'y a aucune vraie solution pour retenir vos mouvements. En conséquence, l'édition dans la vue 3D est imprévisible. Prévoyez de faire toute votre édition dans une des trois autres vues.

Comme je l'ai mentionné plus haut, avoir quatre vues peut être un peu "embrouillant" au début, mais c'est essentiel. Avec une peu de pratique vous vous surprendrez à déplacer un objet dans la vue de côté ou la vue arrière tout en regardant la vue du haut pour le placement. Vous constaterez que vous aurez besoin de chacunne des trois des vues orthogonales dans la plupart des cas lorsque vous éditerez votre géométrie de niveau. Il y a des moments, cependant, où vous aurez besoin seulement d'une vue pour l'édition. Chaque vue de WED fonctionne comme une fenêtre typique de Windows et a un bouton pour réduire au minimum, augmenter au maximum et fermer la fenètre sur la barre de titre. Cliquez sur le bouton d'augmentation maximale sur n'importe quelle vue la fera remplir l'espace entier de vue de WED vous permettant de ce fait d'éditer en utilisant seulement cette vue. Cliquez de nouveau le même bouton restaurera la fenêtre à son format original et à sa place originale.

Amusez-vous à créer, éditer et placer des choses dans les vues et très bientôt vous vous sentirez très à l'aise avec elles.


1.4 – Système de grille de WED

Vous avez du voir que les trois vues orthogonales (dessus, côté et arrière) ont une grille qui s'affiche dans leur fond. Si vous regardez soigneusement la grille vous noterez que quelque chose est peu une étrange à son sujet. Regardez encore si vous n'avez rien constaté.. Ca y est, vous avez vu? Il y a 8 petits carreaux dans chaque grand carreau de la grille:

Pourquoi seulement 8? Je pensais que nous utilisons le système décimal pour cela? Il y a une raison particulière à cela et cette raison est en rapport direct avec la création des jeux 3D en temps réel. Les jeux 3D en temps réel ont besoin de textures qui ont leur taille sous forme d'une puissance de 2 comme 8, 16, 32, 64, 128, 256, 512, 1024, 2048, etc. Une texture qui aurait une taille de 135 pixels sur un de ses côtés seraient invalide. Ce qui fait que le système de grille de WED colle parfaitement avec ce système de puissance de 2. Avoir 8 petits carrés dans un carré plus grand correspond à une puissance de 2.

Vous avez également noté que 3D GameStudio utilise une étrange unité de mesure. Au lieu d'utiliser des centimètres ou des pouces, 3D GameStudio utilise le Quant. Le quant est une unité de mesure arbitraire lorsque vous créez votre niveau mais qui a un rapport direct avec les textures. Chaque quant est égal à un pixel non redimensionné dans votre monde 3D en temps réel. Ceci sera incroyablement utile lorsqu'il s'agira de texturer la géométrie de votre monde 3D et nous reparlerons de cela dans quelques minutes.

Si vous n'avez pas changé les valeurs par défaut de WED, alors chaque petit carré de la grille correspond exactement à 16 quants et il y a 8 petits carrés dans un grand. Ceci nous amène à poser une simple équation basée sur ce que nous savons du système de grilles de WED:

16 quants par petit carré de la grille X 8 petits carrés du grand carré = 128 quants

Vous vous souvenz que je vous ai dit qu'un quant correspondait à un pixel non redimensionné? Bien à présent nous allons nous en servir! Si chaque largeur de carré est de 128 quants et que chaque quant vaut un pixel alors un carré correspond à 128 pixels. Bien et alors me direz-vous? Et alors, vous allez pouvoir texturer parfaitement votre niveau! C'est ce que nous allons faire de ce pas.

Prenons un exemple pour nous aider. Dans WED créer un cube moyen (Medium cube) et positionnez-le de telle façon qu'un de ses coins soit au centre du système de coordonnées de notre monde (là où les 2 lignes vertes se croisent).

Maintenant trouvez et appliquez une texture de 128 x 128 pixels à votre cube:

Vous voyez que la texture recouvre parfaitement chaque face du cube sans se répéter une seule fois. Impreignez-vous bien de ce système de grille de WED et cela vous aidera à positionner parfaitement les textures de vos niveaux enocre et encore. Vous vous en apercevrez dans ce tutoriel.

Vous pouvez avoir une question ou deux au sujet du système de coordonnée universelle de WED que j'ai mentionné ci-dessus. ce système aide fondamentalement à maintenir chaque objet 3D et chaque sommet (point) que vous créez. Par exemple, le point où les lignes vertes se croisent est 0,0,0 dans le système de coordonnées. Un point placé à cet endroit sera à 0 quants du centre dans ses 3 directions (X, Y et Z). Par ailleurs si un point est à 10,10, 100, il sera positionné à X=10, Y=10 et Z = 100. peut-être cela vous parait-il abstrait alors décomposons afin de vous rendre la chose plus compréhensible. Plutôt que de parler d'un monde 3D nous allons parler d'un monde 2D en utilsant un papier millimétré. Je suis sur que vous en avez utilisé dans vos cours de géométrie?

Disons que vous avez une telle feuille avec un quadrillage de 10 carrés vers le haut et de 10 carrés vers la droite, le professeur vous demande de colorier le carré qui se trouve à 5 cases à droite et 6 cases au dessus. Si X est la droite et Y le haut le carré que vous allez colorier sera localisé à 5,6 (X=5 et Y=6). En utilisant cette méthode vous pouvez donner les coordonnées de n'importe quel carré qui se trouve sur votre papier quadrillé.

Cela fonctionne de la même façon dans notre monde 3D sauf que nous avons une notion supplémentaire qui est le Z. (la profondeur). C'est ce système qui est utilisé pour localiser chacun des objets positionnés dans notre monde 3D. Ce système est également utilisé pour déterminer comment nos textures sont placées sur nos géométries.

Chaque texture ajoutée dans notre niveau commence à l'origine du monde par défaut quelque soit l'endroit ou se trouve votre géométrie. Par défaut les textures qui se répètent à l'infini dans toutes les directions commencent à l'origine du monde c'est à dire (0,0,0). C'est pourquoi je vous ai fait placer le cube avec un de ses coins à l'origine du monde. Cela certifiait que votre texture commencerez à ce coin et si c'était une texture de 128 pixels par 128 pixels elle s'adapterait parfaitement à votre cube de 128 quants par 128 quants.

Vous avez noté que j'ai utilisé 2 fois l'origine du monde par défaut. Ce n'est pas par hasard que j'ai utilisé ce mot car nous pouvons toujours changer un défaut. Les textures appliquées à la géométrie dans WED peuvent être glissées le long d'une face afin de les placer exactement où vous voulez. Ayez toujours à l'esprit la façon dont WED gère son système de mesures (et comment les textures inter-agissent avec votre monde 3D) cela vous aidera pour créer la géométrie de votre niveau que vous souhaitez et à la texturer avec précision.


 Part 2 – Tracer et projeter
Ce tutoriel sur la conception de niveau vous montrera comment j'ai conçu le jeu "The Test" et pourquoi j'ai pris les décisions qu'il fallait. Je suis certain que vous prendrez des décisions différentes, mais j'espère que vous glanerez quelque chose du processus dans lequel je suis intervenu.

revenir à la partie 1
allez à la partie 2.1 - Le commencement


 2.1 – Le commencement

Avant que vous puissiez commencer à concevoir un niveau vous devez savoir ce que vous voulez concevoir. Ceci tombe sous le bon sens. Si vous ne savez pas si vous développez l'intérieur d'un vaisseau spatial ou l'extérieur d'une caverne alors vous allez droit vers les problèmes dés le départ. Il devient ainsi impératif que vous preniez quelques décisions principales avant de plonger dans la vraie réalisation de votre monde 3D.

Je ne me suis pas lancé tête baissé dans la réalisation du jeu "The test". Je me suis fixé un certain nombre de règles et voici les directives que je me suis fixées:

- Le jeu doit être petit, seulement 2 pièces comme dans le jeu mission
- Le jeu doit être un jeu de tir à la première personne mélangé avec un léger soupçon d'aventure.
- Le jeu ne doit nécessiter aucn code utilisateur mais doit utiliser le nouveau système de script 3DGS pour les non programmeurs.

C'était à peu près cela. Le genre du jeu m'importait peu. J'ai su qu'avant que je puisse entrer profondément dans la conception des niveaux je devrais me faire une idée juste de ce que je voulais que le jeu soit.


2.2 – Décider du genre de jeu

Je recommanderais cela avant même de mettre en marche votre ordinateur et de démarrer WED que vous vous asseyez avec un morceau de papier et un crayon ou un stylo. Vous en aurez besoin pour commencer à rassembler ce qui deviendra une sorte de document de conception. Gardez à l'esprit toutes les conditions et restrictions que vous avez et puis commencez un brain storming (littéralement : tempête sous le cerveau). J'ai su, par exemple, que le jeu que je concevais allait avoir seulement deux niveaux. Ceci a signifié que j'ai dû proposer quelque chose de simple mais assez intéressant pour garder l'attention du lecteur. J'ai également su que le noyau du jeu était un jeu de tir à la première personne. Ceci a signifié que quelques éléments très traditionnels devraient être mis à jour dans le jeu.

Avec le crayon et le papier à disposition j'ai commencé à noter des idées. La première chose que j'ai décidé c'est du genre des deux niveaux. J'avais récemment développé beaucoup de niveaux de style ancien aussi j'ai choisi quelque chose de futuriste comme base pour le jeu. Ensuite je suis passé à ce que devait être l'objectif du jeu lui-même.

J'ai décidé que l'objectif serait double : rester vivant en dépit des ennemis et rechercher un ou des objets pour terminer le jeu.

Maintenant que j'ai pris quelques décisions de base il est temps de les rendre un peu plus consistantes. Quel sera le type de niveau futuriste? Serait-ce un monde dévasté après l'apocalypse dans lequel le joueur va s'aventurer ou un niveau hight tech où tout est propre et stérile? Et quel sera l'objet que le joueur devra trouver et que fera-t-il dans le reste du jeu? Comme mon jeu ne comporte que 2 niveaux avec lesquels nous allons jouer j'ai pensé qu'il fallait attacher beaucoup d'importance à ces décisions.

J'ai donc décidé que le premier niveau serait une sorte de salle de contrôle avec des éléments de téléportations dont l'un fonctionnerait et l'autre non. L'élément de téléportation en état de marche téléporterait le joueur dans l'autre niveau dans lequel il devrait trouver un élément qui lui permettrait de réparer l'autre élément de téléportation. Réparer l'autre élément de téléportation et s'en servir vous rendrez vainqueur du jeu. A partir de cette idée très simple notre jeu "The Test " commence à prendre forme.

Les Aliens vous ont enlevé et ont décidé de vous mettre à l'épreuve. Le deal est simple, réparez la deuxième machine de téléportation et vous pourrez rentrer chez vous. Une erreur de votre part entrainerait votre mort irrémédiablement. C'est une idée simpliste, mais souvenez-vous, je n'ai que 2 niveaux pour faire mon histoire! .

Maintenant que mon idée a pris forme je réfléchis à l'objet à utiliser. Je décide que chaque téléporteur fonctionne avec 2 crystaux. Le téléporteur en panne n'en a aucun et ses 2 crystaux sont cachés dans l'autre niveau et protégés par quelque chose capable de vous tuer.


 2.3 – Faire les recherches

Après avoir mes idées de base, je m'engage généralement à passer quelques heures de recherche. C'est là où je collecte des idées et commence à consolider ma vision d'ensemble pour la conception du niveau.Je vais certainement regarder des copies d'écrans de jeux, éventuellement jouer un peu à un jeu ou deux mais ce n'est pas la seule chose que je vais faire. Je peux visiter des sites architecturaux, des sites de films, ou simplement n'importe quoi qui puisse me donner des idées. Lorsque je navigue sur Internet, je garde mon logiciel de dessin ouvert et je le nourris d'images qui me semblent être intéressante pour mon projet.

Après avoir récupéré une tonne d'images, je les re-regarde toutes plus en détails et je me débarasse de celles que je ne trouve finalement plus intéressantes.. J'ai créé dans mon logiciel de dessin un document qui a la taille d'une feuille de papier au format A4. Sur ce document je glisse les images qui se rapprochent de mes idées.J'arrange ces images sur la page et lorsqu'elle est pleine je l'imprime. Après avoir imprimé toutes les pages contenant les photos intéressantes, je les dispose près de mon ordinateur et je suis enfin prêt à travailler!

Si vous décidez d'adopter cette approche, gardez, s'il vous plaît, quelques choses à l'esprit. Toutes ces images sont là pour vous donner de l'inspiration pour la conception de votre niveau, elles ne doivent en aucun cas être copiées. En d'autres termes, résistez à la tentation de copier simplement ce que vous voyez des images que vous avez rassemblées. Vous voulez créer votre propre travail, non imiter celui de quelqu'un d'autre.

Bien, maintenant que nous avons notre idée fondamentale et quelques images pour nous aider il est temps de passer à la conception réelle du niveau!


3 - Snap, Crackle et Pop (pourquoi traduire cette phrase qui chante à mes oreilles ;) )

Afin d'obtenir le meilleur de WED et de concevoir des niveaux pour 3D GameStudio nous devons utiliser les outils qui sont à notre disposition et les utiliser pertinemment. Cette section parlera de l'usage de choses telles que l'aimantation, la rotation, la duplication et les déplacements de sommets, de bords et de faces afin de vous aider à créer le type de géométrie de niveau que vous voulez.


3.1– Utilisez l'aimant (snap)

Nous avons découvert WED dans ses grandes lignes dans la première partie et nous avons étudié le système des grilles. Maintenant nous allons mettre en pratique ce que nous avons appris. A chaque fois que vous construisez un niveau dans WED assurez-vous d'aimanter (snap) la grille. Vous aurez ainsi la certitude que votre niveau sera bien aligné et vous limiterez les risques de voir des "trous" apparaîtrent lors de la compilation finale. Je n'ai pas le souvenir d'avoir eu besoin une seule fois de "couper" l'aimant de la grille. C'est fondamentalement un outil essentiel pour la création de niveau.


3.2– Démarrer en douceur

Quand vous commencez à construire votre de niveau commencez simplement. Je n'ai pas l''habitude de commencer par établir une pièce d'un niveau puis d'y ajouter chaque petit détail et de me déplaçer alors vers la prochaine salle. J'ai pour habitude de construire l'ossature de ce que sera la pièce puis de créer les couloirs et les autres pièces attenantes. Une fois que j'ai terminé l'ossature de mon niveau dans WED, je peux commencer à ajouter les détails à chaque section. Le type de détails que j'ajoute dépend du but et de la fonction de la zone.

Par exemple, jetez un oeil à mon premier jeu de couloirs du second niveau de "The Test":

J'avais commencé par faire un couloir de base. Des murs imposants avec un angle de 90 degrés comme tous les couloirs. Le sol était joli et plat.. Au final c'était joli mais sans plus.J'ai donc décidé de donner un peu de cachet à ce couloir. La première chose que j'ai décidé c'est que les murs ne seraient pas à 90° mais légèrement inclinés vers l'intérieur:

Puis comme j'ai trouvé le sol trop classique, j'ai créé une zone en creux recouverte de métal

Pour finir j'ai ajouté des structures de soutènement au mur pour couper la monotonie du couloir. J'ai fait cela car je savais que ça ajouterait des ombres superbes plus tard:

Puisque nous en sommes aux couloirs, regardez ce couloir dans une autre partie du même niveau.

Ce couloir est assez différent du précédent. Il y a deux raisons à cela. La première raison est que c'est une zone différente du niveau. La deuxième raison c'est que j'ai souhaité que le joueur ne tombe pas dans la routine de l'ennui. Utilisez votre créativité pour faire des zones intéressantes et uniques mais gardez en même temps une ligne directrice dans l'ensemble de votre niveau.


3.3– Duplication

C'est une vieille rengaine, pourquoi réinventer la roue? Je pense que vous devriez réfléchir à cette question pourtant fort simple particulièrement lorsque vous créez des niveaux dans WED. Si vous devez répeter certaines parties de votre niveau, pourquoi devriez-vous les créer encore et encore? Non seulement ça devient vite répétitif et insupportable pour le développeur mais en plus vous perdez votre temps.. Vous pouvez écourter le processus de création en dupliquant des blocs individuellement ou des sections complètes de votre niveau pour les utiliser dans une autre zone.

La duplication peut être faite de trois façons :

- Maintenir la touche Maj enfoncée pendant que vous déplacez l'objet à dupliquer avec la souris, le bouton gauche étant maintenu enfoncé
- En utilisant la combinaison de touches CTRL + D (D comme duplication)
- En utilisant la fonction copier / coller de Windows

Chaque méthode peut vous donner un résultat légèrement différent. nous étudierons donc chacune d'entre elles.

Maintenir la touche Maj enfoncée pendant que vous déplacez l'objet à dupliquer avec la souris crée une copie de l'objet qui suit le curseur de la souris lorsque vous le déplacez à l'intérieur de votre vue. Lorsque vous relachez le bouton de la souris l'objet se positionne là ou se trouvait le curseur de la souris. C'est la méthode de duplication que j'affectionne et utilise le plus car elle permet de dupliquer et positionner rapidement ce dont vous avez besoin.

Pressez les touches CTRL et D simultanément créera également une copie de l'objet sélectionné. La copie sera placée en léger décalage en X et en Y par rapport à l'original en fonction des paramètres entrés dans les préférences de WED.

Le copier / coller Windows a deux comportements possibles selon la façon dont vous procéder. Soit en utilisant les raccourcis Windows pour le copier / coller qui sont (CTRL+C et CTRL+V) dans ce cas l'objet dupliqué apparaîtra toujours au centre de votre vue. L'autre façon d'utiliser la fonction copier / coller est avec le menu contextuel obtenu par le clic droit de la souris. Lorsque vous cliquez avec le bouton droit de la souris dans une vue, une fenêtre avec un certain nombre de choix s'ouvre dont une fonction COPY (copier) et une fonction PASTE (coller). La fonction copier (copy) de ce menu est la même que le raccourci Windows mais la fonction coller (paste) puisque lorsque vous l'utilisez à partir de ce menu, l'objet dupliqué se positionnera là ou se trouvait le curseur de la souris lorsque vous avez cliqué sur le bouton droit.

Vous pouvez reproduire tout ce que vous voyez dans les vues de WED. peu importe qu'il s'agisse d'un morceau de la géométrie de niveau, d'un groupe, d'un sprite, de lumières ou de modèles. s'il est là alors il peut être reproduit. Jetons de nouveau un coup d'oeil à ce couloir :

Vous pouvez voir de nombreuses répétitons. Pensez-vous vraiment que j'ai passé mon temps à créer chaque morceau avec mes petits doigts tout fatigué? Que nenni, j'ai réalisé la forme qui me plaisait, je l'ai groupée puis je l'ai dupliquée autant que nécessaire. J'espère que ce chapitre duplication vous aidera à gagner du temps dans votre création de niveau.


 3.4– Rotation

Un autre outil que vous serez appelé à utiliser est l'outil de rotation

Peut-être que le couloir que vous venez juste de créer aurait besoin d'être tourné vers la droite ou vers la gauche. Pas de problème, dupliquez-le et tournez-le tout simplement selon vos besoins. Bien, mais malheureusement ce n'est pas aussi simple que cela, regardez cette image pour comprendre pourquoi:

Comme vous pouvez le voir, nous devrons compléter la section manquante du hall ce que ne peut pas faire une duplication suivie d'une rotation. Néanmoins, les deux sections du hall nous fourniront un guide pour nous aider à compléter les lacunes. Tout que nous devons faire c'est d'apparier le haut de la nouvelle géométrie avec les deux sections et ainsi nous ferons un joli coin:


 3.5– Déplacement de sommets (Vertex), de bords (Edge) et de faces

Queques fois nous aimerions avoir une forme qui ne se trouve pas dans les formes fournies en standard. Elle peut être créée en déplaçant les sommets d'un objet (les petits points qui relient 2 traits entre eux), les bords (les traits eux-mêmes) ou les faces (l'espace qui se trouve entre les sommets et les bords).

Vous pouvez accéder aux sommets, bords et faces des objets en utilisant les boutons suivants sur la barre d'outils de WED.

A ce point du tutoriel nous devons faire une pause et discuter des restrictions actuelles dans WED en particuliers et dans 3D GameStudio en général. Comprendre ces restrictions peut vous éviter d'avoir un certain nombre de cheveux blancs dans le futur. Actuellement le moteur de 3D GameStudio utilise le BSP (Binary Space Partition). BSP présente de nombreux avantages mais également quelques inconvénients.et nous ne profiterons pas de ce tutoriel pour lancer une discussion sur les pour et les contre du BSP, mais il faut faire attention aux quelques restrictions imposées par BSP lorsque vous construisez vos niveaux.

BSP ne vous autorise pas à faire des surfaces CONCAVES. Je suis persuadé que beaucoup d'entre vous n'êtes pas familiarisé avec ce terme aussi voici la définition donnée par le dictionnaire :

Se dit d'une surface présentant une partie creuse

Ce type de surface n'est pas permis dans les systèmes qui utilisent BSP en standard, c'est le cas de 3D GameStudio.

Je vous entend vous demander : "mais alors, comment puis-je créer de telles surfaces lorsque j'en ai besoin si je suis soumis à de telles restrictions?" Ce que vous devez faire c'est d'utiliser plusieurs surfaces non concaves et de les combiner entre elles pour obtenir la surface concave que vous souhaitez obtenir.

Vous devrez garder ceci à l'esprit quand vous travaillez avec les sommets, les bords et les faces d'une géométrie parce qu'il est très facile de créer, par distraction, une surface concave.Pas d'inquiétude, WED vous avertira lorsque vous créerez une surface concave. Quelques fois vous créerez une surface concave pendant la création d'une surface non concave. Si c'est le résultat que vous attendiez alors cliquez sur ignore à la question posée par WED, si ce n'est pas ce que vous souhaitiez alors cliquez sur OK et vous déplacez dans WED remettra votre géométrie à sa forme originale et vous pourrez essayer autre chose.

Maintenant que nous venons de comprendre une très importante restriction de WED/3D GameStudio nous pouvons commencer à utiliser la manipulation des différentes formes géométriques dans le but de créer les types de surface souhaitées. . La combinaison de cette connaissance avec l'aimantation de la grille nous évitera beaucoup d'ennuis lorsque nous aborderons la création de notre geometrie de niveau. Les futures versions de WED incluront un nouveau dispositif appelé VERTEX SNAPPING. Celui-ci rendra WED bien plus puissant car vous pourrez non seulement aimanter des objets, des sommets, des bords et des faces à la grille, mais également aux sommets d''autres objets. Ceci vous permettra d'aligner parfaitement vos objets avec l'autre objet. Ce dispositif est en version bêta au moment où j'écris cet article et donc sera peut-être même disponible quand ce tutoriel sera en ligne.

Nous avons à présent quelques idées sur la façon de commencer à construire l'espace 3D réel mais maintenant nous devons le faire se ressembler à quelque chose d'autre que du plastique ordinaire et blanc (et nous ne voulons certainement pas utiliser la texture par défaut de WED). aussi passons à la prochaine partie du tutoriel et parlons de la texturisation.


Part 4 - Une image vaut tous les discours

Les textures peuvent faire ou défaire un niveau. Une simple boîte peut être faite pour ressembler à n'importe quelle vieille caisse en bois ou à un bac à poissons. Tout dépend des textures que vous lui appliquez. Cette section vous expliquera comment texturer votre niveau et vous donnera des trucs, astuces et conseils.


4.1– Plus grand ne veut pas dire meilleur

Vous devez prendre des décisions sages sur la taille des textures à utiliser pour n'importe quelle partie et tous les morceaux de la géométrie dans votre niveau. Plus grande sera la texture et plus vous utiliserez de mémoire vidéo. Si trop de mémoire vidéo est utilisée alors votre niveau peut ne pas exécuter ou, s'il s'exécute il ressemblera plus à une projection de diapositives qu'à un programme 3D en temps réel. Regardons le rapport qu'il y a entre la taille de la texture et la mémoire vidéo

Taille de la texture | Memoire utilisée
512 x 512 | 746 Kb
1024 x 1024 | 2992 Kb
512 x 1024 | 1496 Kb
256 x 256 | 187 Kb
256 x 512 | 374 Kb

Comme vous pouvez le voir, plus la taille de la texture est grande et plus vous utilisez de mémoire vidéo (logique). Si vous créez un niveau qui n'utilise que des textures de 1024x1024(ou plus grandes) vous allez rapidement saturer la mémoire vidéo. Lorsque que nous nous apprêtons à texturer nos niveaux nous devons penser soigneusement à chaque texture que nous appliquons pour voir si la consommation de mémoire de cette texture est justifiée par sa valeur au niveau global. Pensons à ceci pendant un moment.

Imaginons que nous sommes en train de texturer notre niveau et qu'il est temps pour nous de donner une texture au plafond. Nous devons nous poser une question. Le joueur regardera-t-il le plafond ? Si oui, combien d'heure passera-t-il à le regarder ? Le joueur devra-t-il regarder le plafond afin de résoudre un puzzle dans le jeu ? Les questions comme celles-ci (et d'autres) vous aideront sérieusement à décider la taille de la texture que vous placez là. Dans la plupart des jeux , le joueur s'occupe rarement des plafonds. Il regarde habituellement autour d'un coin pour voir qui va l'attaquer. Si c'est le cas dans votre jeu, alors pourquoi gaspiller de la précieuse mémoire vidéo sur une texture de plafond ? Pourquoi ne pas utiliser une texture plus petite, même si ce n'est pas aussi joli et craquant qu'une texture plus grande?

D'autre part, disons que votre jeu exige du joueur d'examiner un morceau de la géométrie de niveau de manière très approfondie pour rechercher un indice. Si c'est le cas, alors vous pouvez très bien décider d'utiliser une plus grande texture de sorte que le joueur ne voit pas trop de différents Pixels quand il l'examinera de près.


4.2– Utiliser le redimensionnement des textures

Après avoir lu la section précédente vous vous demandez peut-être comment une texture plus grande peu mieux rendre? Pour vous un quant vaut un pixel! Si c'est ce que vous pensez alors vous pensez bien. Mais rien ne nous empêche de bousculer les règles établies de temps en temps et de faire en sorte qu'il y ait plus d'un pixel dans un quant. Nous pouvons faire cela en redimensionnant les textures (scale). La façon de redimensionner une texture dépend de si la texture est déjà appliquée à la géométrie ou non.

Si la texture n'est pas appliquée à la géométrie du niveau, vous avez simplement besoin d'accéder aux paramètres de la texture par un clic droit de la souris sur la texture dans la vue texture sur la gauche et de sélectionner “Settings”: (paramètres)

Alors un panneau comme celui-ci apparaîtra:

Vous noterez deux zones d'enregistrement de texte nommées “x scale” et “y scale”. Chacune d'elles a par défaut 1.000 d'entré dans le champ. Ce qui signifie que le facteur de redimensionnement de la texture est un. Augmenter ce nombre revient à augmenter la taille de la texture. Par exemple, si vous changez 1.000 par 2.000 vous doublerez tout simplement la taille de votre texture. Dans ce cas si la texture faisait 128 par 128 pixels, elle pourra remplir un espace de 256 x 256 pixels. Augmenter la taille d'une texture permet de remplir une zone plus grande mais ça signifie également que chaque pixel est plus grand. Si vous vous souvenez de ma formule un quant = un pixel, je parlais bien entendu d'un pixel non redimensionné. Redimensionner la texure par le facteur d'échelle 2.000 change bien entendu cette équation aussi un quant vaut 1/2 pixel pour cette texture. Ce qui signifie que le joueur verra plus facilement les pixels.

Par déduction logique, si vous réduisez la texture c'est l'inverse qui va se produire. Une texture redimensionnée avec un facteur d'échelle de 0.500 fera la moitié de sa taille ce qui signifie que notre texture de 128 x 128 pixels occupera un espace de 64 x 64 pixels et que vous aurez 2 pixels pour un quant. Et deux pixels dans un quant donnera deux fois plus de clarté à la texture. En d'autres termes les pixels apparaîsent plus près les uns des autres dans le monde 3D et les yeux voient mieux les mélanges de pixels. Mieux que cela, les textures réduites apparaîssent meilleures lorsqu'on s'approche d'elles.

Je vous imagine en train de vous dire, mais alors j'ai juste à réduire toutes mes textures! Bien que cette pensée soit tentante, ce n'est pas toujours la meilleure chose à faire. En effet redimensionner les textures signifie que vous utilisez des textures plus grandes que nécessaire et que donc vous utilisez de la mémoire vidéo inutilement et nous savons que cela est préjudiciable aux performances de notre jeu. Vous devez donc avoir un peu de sagesse dans l'utilisation de la réduction des textures et ne pas en mettre sur tout votre niveau.

Plus tard, dans la section sur l'éclairage de votre niveau (partie 5) je vous apprendrais un autre secret à propos du redimensionnement des textures.Ce sera également un autre point à prendre en considération pour le choix de la taille de vos textures.


4.3– Assortir les couleurs de vos textures

Il n'y a rien de pire que de regarder un niveau fait par une personne qui aurait utilisé toutes sortes de texures trouvées sur le Web. Celle-ci ou celle-là, choisie pour on ne sait quelles raisons et toujours appliquées aléatoirement sur les murs, les sols et tout ce qui peut avoir besoin d'une texture. Certaines personnes devraient prendre un peu plus de soins et s'assurer qu'une texture bois est utilisée pour une surface en bois et une texture pierre pour une surface pierre mais même cela n'est pas suffisant. Les textures doivent vraiment être assorties au niveau des couleurs pour faire "chanter" le niveau. Ce n'est pas une tâche facile et ceux qui y arrivent naturellement ont de la chance. Certains ont ce don (c'est ce que je pense) et d'autres pas. Je ne suis pas de ceux qui ont le don de pouvoir assortir les couleurs c'est pourquoi je dois travailler très dur pour cela. J'ai quelques programmes et ouvrages qui parlent de ce sujet pour m'aider dans ma tâche.

Il y a cependant des solutions de rechange à acheter le logiciel ou les livres pour vous aider à cette tâche,. Vous pouvez utiliser l'Internet comme point de recherche. Recherchez les images sur le Web qui attirent votre attention. Regardez comment elles ont employé la couleur pour attirer votre attention et quelles combinaisons elles ont utilisées ensemble. Voyez comment elles fonctionnent (ou ne fonctionnent pas) et pourquoi. Il m'arrive souvent de récupérer une image ou une copie d'écran d'une page Web que j'amène dans mon logiciel de peinture favori et à l'aide du compte goutte je récupère les différentes nuances de couleur pour me faire mon propre nuancier. Et chaque texture que je vais créer pour une zone particulière aura pour racine ce nuancier


Part 5 - Donnons du brillant!

L'éclairage est l'un des concepts les plus importants pour la finalité de votre niveau. Sans séclairage votre niveau semblera doux et plat. Avec un mauvais éclairage votre niveau paraîtra encore plus mauvais. Par contre, si vous obtenez un bon éclairage alors même un niveau moyen pourra sembler bon.


5.1 – Astuces sur l'éclairage

L'éclairage est une des dernières choses que je travaille dans ma conception de niveaux. C'est également un endroit ou je passe beaucoup de temps. Avant d'aller plus en profondeur dans l'éclairage de votre niveau nous allons découvrir quelques astuces concernant l'éclairage.

Astuce #1 - On utilisera rarement une lumière purement blanche

La lumière est faite de couleurs. En fait toutes les couleurs sont présentes dans ce qu'on appelle une "lumière blanche". Les objets absorbent et reflètent les couleurs. Les couleurs que nous voyons sont celles qui sont réfléchies. Ceci signifie que la lumière colorée est tout autour de nous.

3D GameStudio, comme la plupart des moteurs 3D, ne permet pas à la couleur d'être absorbée ou reflétée de quelque façon. Par conséquent nous devons simuler ceci nous-mêmes.Une façon pour arriver à cela consiste à ne pas utiliser de lumières blanches. Au lieu de cela utilisez un peu de couleur de temps en temps.

Astuce #2 - Utilisez des lumières douces

À mon avis il vaut mieux d'utiliser plusieurs lumières douces qu'une grande très forte. Avec les lumières douces vous avez beaucoup plus le contrôle sur ce qui doit être éclairé, ce qui ne doit pas l'être et avec quelle quantité de lumièr. Les lumières énormes et lumineuses tendent à effacer vos textures et sont généralement trop dures.

Astuce #3 - utilisez une ambiance de base pour votre niveau

Je n'éclaire jamais complètement un niveau en utilisant uniquement la lumière d'ambiance.La première chose que je fais et de mettre une ambiance de base pour tout le niveau. Le paramétrage de la quantité de lumière ambiante dépend de l'ambiance que je souhaite donner à mon niveau et de la façon dont je veux que les zones non éclairées par la suite apparaîssent. Maintenant vous pouvez employer les lumières de niveau autant que nécessaire afin de mettre en valeur l'humeur, l'ombrage et l'éclairage des zones que vous souhaitez. Pour paramétrer l'ambiance du niveau allez à File>Map Properties et cliquez sur l'onglet "Sun".

Astuce #4 - Essayez de ne pas utiliser la lumière du soleil

Je ne sais pas pour vous mais personnellement je n'ai jamais été satisfait des ombres et de l'éclairage créés par la lumière du soleil de 3D GameStudio et j'ai constaté que j'ai plus de contrôle de l'éclairage et que j'obtiens de meilleurs résultats quand j'utilise les lumières de niveau standard. En conséquence, j'utilise rarement, pour ne pas dire jamais, la lumière du soleil de 3D GameStudio. J'envisagerai l'usage de la lumière du soleil pour de grandes scènes extérieures, mais jamais pour une scène d'intérieur.


5.2 – Où placer les lumières

Ce n'est pas une chose simple à décrire.La meilleure chose que je peux vous dire c'est qu'il faut placer une lumière là où il faut bien voir les choses. Je sais. que ça ne vous aide pas beaucoup, mais c'est presque ce que je puisse faire de mieux. La dernière chose que nous voulons faire est de placer une lumière, compiler le niveau, vérifier l'éclairage, trouver les endroits qui ne sont pas terribles et recommencer le processus encore et encore jusqu'à être satisfait de tout l'éclairage.Voyons si je peux vous trouver quelque chose qui vous aide dans ce processus.

La première chose à faire est de voir où des lumières doivent être placées. Oui, il y a des endroits qui sont évidents. Jetez un oeil à votre niveau, Est-ce qu'il n'y aurait pas un plafonnier quelque part, Peut-être avez-vous une lampe ou un objet sensé envoyer de la lumière. Si c'est le cas vous devez placer une lumière qui fera que l'objet jettera de la lumière dans votre niveau. Souvenez-vous d'une des astuces vues plus tôt, utilisez des lumières douces et si une ne suffit pas pour obtenir ce que vous voulez, mettez en plusieurs. Placer les lumières avec les objets émettant de la lumière participera fortement au réalisme de votre scène.

Si vous avez une lampe de plafond et lui ajoutez une lumière vous découvrirez rapidement que les lumières de WED ne fonctionnent pas tout à fait comme de vraies lumières. la raison en est que les textures et la géométrie de WED n'absorbent pas ou ne réfléchissent pas la lumière comme de vrais objets. Par conséquent, dans la vie une ampoule peut éclairer toute une salle entière, mais pas la même lumière dans WED. Vous devrez alors certainement utiliser plusieurs lumières pour obtenir un effet plus réaliste. Souvenez-vous de notre astuce, utilisez la lumière ambiante avec les lumières est un long chemin.

Sans compter qu'en l'absence de la lumière du soleil que je n'utilise pas pour les raisons expliquées plus haut , il faudra placer des lumières pour simuler l'éclairage normal derrière les objets sensés laisser passer la lumière comme les fenêtres, les lucarnes etc Encore une fois, une bonne lumière ambiante et des lumières bien disposées tout au long de votre niveau feront que votre niveau sera vraiment digne des plus grands.

Une chose à se rappeler c'est que beaucoup de lumières n'ont pas de bords durs. La plupart des éclairage sont doux. Gardez ceci à l'esprit en ajoutant l'éclairage à vos niveaux. Les simples lumières de WED tendent à paraître plus dures que la plupart des éclairages que nous voyons. La clé pour faire un niveau qui paraîsse très bon est enracinée dans l'observation. vous devez devenir un observateur de tout ce qui est autour de vous. Jetez un regard à la lumière dans votre chambre, votre bureau, par la fenêtre principale de votre maison ...Regardez autour de vous, que voyez-vous?

Comment fait la salle pour s'allumer? Qu'est-ce qui jette cette ombre? Pourquoi cela et pourquoi pas ceci? Une fois que vous devenez un bon observateur de la réalité alors vous êtes prêt pour créer votre propre version de la réalité dans 3D GameStudio !


Part 6 - Divers.

Cette section du tutoriel couvrira des considérations diverses.


6.1– ajouter de petits détails

Ce sont vraiment les petits détails qui donnent de la vie à un niveau. Ce sont souvent les choses que nous négligeons ou auquelles nous ne pensons généralement pas mais néanmoins ces choses sont là et nous devrions leur prêter de l'attention pour nos niveaux. Je parle des choses comme les prises électriques, les interrupteurs sur des murs, des irrégularités ici et là, une tonne d'autres choses que, si nous sommes des observateurs attentifs, nous verrons tous autour de nous tout le temps.

C'est également avec ces détails que nous devons être très attentifs. Si nous ne prenons pas de soin à la façon dont nous ajoutons ces détails alors nous constaterons que ces détails ralentissent notre taux d'affichage d'une façon considérable. Il faut donc trouver le bon équilibre .Il y a quelques pistes à suivre pour ajouter les détails qui ne nous coûteront rien en taux d'affichage mais qui nous prendrons un peu de temps à les créer. Une de ces pistes coniste à ajouter certains de ces détails aux textures elles-mêmes. Si vous créez une texture pour un mur, alors pourquoi ne pas ajouter une prise électrique directement à la texture? Il y en a habituellement plusieurs le long d'un simple mur alors une peu de répétition avec la texture ne devrait pas être un problème. C'est à ces sortes de détails que nous devrions penser lorsque nous développons notre textures.

Il y a d'autres pistes pour ajouter des détails. Une de ces pistes est d'utiliser des sprites. Les sprites sont la solution à utiliser comme décalques pour des choses non-repetitives comme une fissure dans un mur, une affiche qui se trouve uniquement dans un endroit, un journal ou le morceau de papier sur le plancher et d'autres choses du même acabit. Vous devrez placer un petit code pour que le sprite soit toujours face à la caméra (référez-vous au manuel de C-Script pour plus de détails), mais l'utilisation des sprites peut être pertinemment une très bonne piste pour ajouter des détails et empêcher la répétition. Si vous ajoutez un peu de transparence à votre sprite vous pouvez faire que le sprite semble être une partie de la texture

Vous pouvez également ajouter les détails 3D en utilisant des modèles. Ceci peut inclure des choses comme des livres, des boîtes de soda, des bouteilles et beaucoup d'autres choses. puisque ces éléments ne sont pas les éléments "principaux" dans un jeu (c.-à-d. le joueur ne va pas leur prêter trop d'attention) et que donc ils n'ont pas besoin d'être des modèles avec beaucoup de polygones. Tout à fait l'opposé. Il y a un avantage à utiliser les modèles 3D pour des détails et c'est que vous pouvez les animer si vous le désirer. Vous pouvez faire, par exemple, un morceau du papier qui bouge dans le vent, des bouteilles qui se cassent quand elles reçoivent un coup et beaucoup d'autres choses.

Comme pour choisir les textures appropriées, ajouter des détails demande à ce que vous y réfléchissiez avant. Prenez votre temps, planifiez votre niveau en amont et ajoutez les détails que vous pensez qu'ils vont pouvoir donner de la vie à votre niveau. N'en abusez simplement pas. Trop de détails peut distraire le joueur et le détourner du jeu


6.2– Utiliser les entités de carte

Les entités de carte sont très utiles pour beaucoup de choses. Nous les utilisons pour les portes qui doivent s'ouvrir et se fermer, les murs qui doivent se déplacer, les plateformes qui se déplacent et beaucoup d'autres choses.Il y a quelques restrictions lorsque vous utilisez les entités de carte qu'il est bon de garder à l'esprit, comme par exemple que les entités de carte ne sont pas affectées par l'éclairage de niveau et en conséquence, elles ne jettent pas d'ombres créées par les lumières de niveau. Il est donc très facile de créer des entités de carte qui donnent l'impression de ne rien avoir à faire dans votre géométrie de niveau. En d'autres termes, elles peuvent apparaître aussi incongrue qu'un cheveu dans la soupe. Il y a heureusement quelque chose que nous pouvons faire pour corriger cela.

Nous pouvons pré-éclairer nos entités de carte en les appariant avec notre géométrie de niveau. Si vous pré-éclairez correctement vos entités de carte alors elles seront pratiquement indistingables du reste de votre niveau. Voici ce qui je fais pour pré-éclairer correctement mes entités de carte.

Je crée l'entité de carte dans le niveau lui-même où elle est censée se trouver. J'efface alors tout le reste du niveau excepté l'entité et toutes les lumières qui l'affecteraient. Une fois que mon entité est seule dans WED je la sauvegarde sous un nom différent et je la compile en cochant l'option BUILD MAP ENTITY et je laisse WED faire son travail. Puisque j'ai gardé les lumières avec l'entité, WED construira les cartes de lumières la concernant ce qui aura pour effet de l'apparier avec le niveau auquel appartient l'entité.Après la compilation, je peux ouvrir mon niveau initial et lui ajouter l'entité. Une fois que le niveau est compilé et exécuté, alors l'entité de carte devrait s'apparier avec le reste du niveau.


6.3– Ayez du plaisir!

Croyez-le ou pas, ceci est probablement l'un des aspects les plus importants de la bonne conception de niveau. Si vous n'avez pas de plaisir à le faire alors vous aurez probablement le besoin de placer le niveau de côté pendant un moment, trouver autre chose à faire et revenir à lui quand vous avez l'esprit clair et que vous pouvez de nouveau regarder votre niveau avec plaisir et une attitude positive.. Croyez-moi, si vous n'avez pas de plaisir tout en développant votre niveau alors cela se verra et les joueurs n'auront aucun plaisir à jouer. Après tout, pourquoi sommes-nous tous devenus impliqués avec quelque chose comme 3D GameStudio? Nous le faisons pour gagner de l'argent et pour devenir riches? Je n'espère pas. Vous pourriez faire de l'argent et vous pourriez devenir riche, mais comment profiter du succès si on est triste et déprimé. C'est quand même mieux d'apprécier ce que vous faites. Aussi, asseyez-vous confortablement, détendez-vous, placez votre boisson préférée à côté de vous (et faites attention à ne pas la renverser sur votre clavier ;) !) et mettez toute votre énergie pour créer un niveau vraiment génial qui épatera tout le monde. Rappelez-vous simplement que vous devez avoir du plaisir à le faire.


WED Tutorial: Introduction

Introduction

Ce tutoriel est conçu pour vous faciliter la prise en main de l'éditeur de monde de 3D GameStudio (WED). En développant un petit jeu d'un niveau, en commençant par un écran vide, vous finirez par connaître WED et le moteur A6. Parfois il vous faudra un peu ruser, mais il y aura un bon nombre d'aide et de conseils tout au long afin de vous aider à devenir un maître en conception de niveau.

Voulez-vous un aperçu?

Naturellement vous voulez! Vous voulez marcher dans un niveau et voir ce que vous êtes sur le point de faire avec vos petits doigts. OK, alors démarrons notre niveau test. À la fin de ce tutoriel le niveau que vous créez sera tout à fait semblable à celui-ci:

  • Démarrez WED (ce que vous avez probablement déjà fait).
  • Ouvrez FIRST.WMP (File / Open).
  • Cliquez sur File/Build ou simplement [image] et assurez-vous que Level Map soit coché.
  • Cliquez sur OK pour compiler le niveau. Puis lorsque la compilation est terminée, cliquez de nouveau sur OK.
  • Vous pouvez à présent démarrer le niveau en cliquant sur File/Run ou [image] et OK de nouveau!
Lorsque le niveau s'exécute, essayez de presser les touches [6] et [7] pour voir ce qui se passe.

Il est temps de commencer!

Êtes-vous prêt ? Bien mais laissez-moi vous expliquer d'abord ceci : Pour rendre l'intégralité de cette expérience vraiment authentique, Conitec a proposé quelque chose de spécial : un débutant - ce que je suis - obtient le paquet entier du moteur et créera un niveau avec vous point par point. Ingénieux ! Ainsi, à votre place, je tomberai dans tous les pièges, je rongerai tous mes ongles, je m'arracherai tous les cheveux et je terroriserai le personnel du support avec des questions stupides.

Avant que nous ayons accompli ce cours d'instruction nous aurons une commande ferme de WED, après quoi - comme une énigme que vous pourriez dire - nous prendrons un regard aux manuscrits. Ainsi maintenant que vous ne pouvez pas attendre pour enrouler vos douilles et pour obtenir commencé, cliquetez le prochain lien ci-dessous et nous pouvons commencer par notre première pièce !


WED Tutorial:First Room I

Première étape - Première pièce - Partie I

A présent je suppose que vous avez installé 3d Game Studio. Autrement ce serait vraiment mieux si vous le faisiez maintenant. Ouvrez WED et préparez-vous à affronter notre premier challenge:

Hum, pas très excitant ce que nous voyons ici. L'interface utilisateur nous parait familière aussi ce ne doit pas être trop difficile à utiliser. C'est d'une main ferme que nous cliquons sur File / New et regardez, nous obtenons une nouvelle surface de travai vierge avec menu et barre d'icônes, avec une fenêtre étroite sur la gauche (la fenêtre de projet) et 4 différentes fenêtres (3 en 2D et une en 3D). Les fenêtres 2D ont une grille en fond qui nous sera utile pour l'édition.

Pour découvrir l'usage de chacune de ces fenêtres, nous allons construire de ce pas une petite maison:

Vous pouvez faire cela en utilisant les menus déroulants Object / Add Primitive / Misc / House ou en cliquant sur l'icone [image] -et en allant sur Add Primitive / Misc / House.

Suite à cela, différentes choses se produisent:

Nous pouvons voir que chacune des fenêtres 2D offre un angle de vue différent pour notre petite maison : Top - vue de dessus, Back - vue de l'arrière et Side -vue de côté.

La fenêtre 3D (qui se trouve par défaut en haut à droite) est censée vous donner une prévisualisation approximative de votre niveau. Si vous cliquez sur le menu View vous pouvez choisir entre une présentation wire framed (fil de fer), solid (solide) - et, car nous allons bientôt intégrer des textures, également textured (texturées).

Cliquez dans une fenêtre pour la sélectionner puis maintenez le bouton droit enfoncé pendant que vous bougez la souris, vous pouvez défilez dans la fenêtre et zoomer en utilisant la molette de la souris. Si vous êtes un tant soit peu joueur, allez-y: déformez les fenêtres individuellement, agrandissez-les, réduisez-les, déplacez-les... Par View / Add View vous pouvez en créer de nouvelles et si pour finir vous avez mis le désordre que je pressens ce n'est pas grave, cliquez sur View / Default Layout et tout rentrera dans l'ordre (dans le cas ou vous auriez perdu une fenêtre vous pouvez l'ouvrir de nouveau par View / Add View:

Vous avez probablement déjà noté que votre objet était parfois blanc et parfois rouge selon que vous cliquiez dessus ou à côté. Dans la plupart du temps le rouge signifie "attention!", C'est aussi ce qui se passe ici. S'il y a quelque chose de rouge dans votre niveau, cela signifie que vous l'avez sélectionné et c'est cet objet qui sera affecté par la prochaine commande. Sans compter que WED ne démarre pas toujours en mode select (Mode / Object Select) ou juste en cliquant sur [image]. vous pouvez tout déselctionner simplement en cliquant sur la croix sur la gauche:

Si vous pensez que ma maison est plus grande que la votre, c'est exact. J'ai redimensionné (scaled) la mienne. Puisqu'il ne se passe rien en mode select je passe en mode redimension (scale) par Mode /Object Scale ou [image], je selectionne mon objet en le cliquant, il devient rouge, et je joue avec sa taille en promenant la souris tout en tenant le bouton gauche enfoncé jusqu'à obtenir la taille désirée. Vous noterez que ce n'est ni très pratique ni très précis comme méthode, ce dont nous aurions besoin c'est d'un facteur d'échelle, d'une unité de mesure. Nous en connaissons bien une, elle s'appelle "quant" et elle est l'unité utilisée par WED pour afficher toutes les coordonnées. Malheureusement elle ne correspond pas à une valeur de taille fixe comme par exemple un pouce ou un centimètre sur lequel nous pourrions compter.

A quoi correspond réellement un quant à l'intérieur de notre niveau dépendra uniquement de vous! L'idéal étant de se repérer par rapport à un objet ayant une taille connue, une hauteur sous plafond (en général 2,50 m), la taille d'un personnage... Imaginons que votre joueur a une taille de 90 quants de hauteur dans WED et que dans la vie réelle il mesure 180, on en déduit qu'un quant équivaut à 180 : 90 = 2cm. Donc une pièce de 4 m² dans votre niveau, 2m x 2 m ou 200cm x 2000 cm fera exactement 200 x 200 quants. Vous voulez que votre joueur ne mesure pas plus de 45 quants en taille, alors un quant équivaudra à 4 cm!

Pourquoi faire si compliqué, vous demandez-vous? La raison en est très simple, WED limite la taille d'un niveau à 100 000 quants et dans ces 100 000 quants vous pouvez aussi bien faire tenir un bâtiment, qu'une ville entière, voire un univers. Vous comprenez bien que si vous voulez loger 10 000 maisons là ou vous en mettiez 100 auparavant, la taille des maisons ne sera pas la même.Il vous appartient donc en fonction de ces différents paramètres, de vous fixer votre propre echelle de valeur en gardant à l'esprit que la taille d'un joueur reste la référence et que vous adapterez sa dimension à votre niveau en jouant sur la fonction de redimensionnement scaled

Et à présent vous aimeriez savoir qu'elle est la taille d'un quant sur votre écran? Jetez un oeil sur la barre d'état en bas de la fenêtre WED, il y a plusieurs informations utiles : le mode actuel (normalement scale si vous suivez ce tutorial à la lettre) la fenêtre survolée par la souris et les coordonnées (par rapport au centre du niveau) actuelles de la souris X, Y et Z en quants. Et complètement à droite les coordonnées X, Y et Z du centre de l'objet sélectionné. Vous vous dites : Génial, puisqu'un carré de ma grille correspond à tel part d'un quant, j'ai juste à compter les carrés. Malheureusement ce n'est pas aussi simple que cela. La grille change lorsque vous utilisez la fonction zoom (molette de la souris). Autrement en ayant une vue d'ensemble du niveau vous auriez de tous petits petis carrés. Heureusement dans la barre de titre des fenêtres de vues vous avez l'information concernant la taille d'un petit carré en quants. Par exemple "Grid: 16x8" signifie qu'un petit carré fait 16 quants et qu'il y a 8 petits carrés dans un grand.

Si cela vous parait un peut trop théorique, ne vous inquiétez pas. Vous aurez vite le coup de main pour les proportions, une fois notre première pièce de faite, vous verrez, ça ira tout seul!

Bien revenons à nos moutons ou plutôt à notre petite maison : étirez-la dans la fenêtre vue de dessus (top), en faisant cela vous pouvez noter que notre maison se modifie également dans les autres vues. Cependant dans la fenêtre vue de dessus vous ne pouvez modifier que ce que vous y voyez, si vous souahitez non seulement agrandir sa longueur et sa largeur mais également sa hauteur vous devez changer de fenêtre. Essayez de le faire avec la fenêtre vue de derrière (back). Amusez-vous avec chacune des fenêtres, y compris la fenêtre 3D et essayez également les autres modes, déplacement d'objet

Object Move ou [image] et et rotation d'objet Object Rotate ou [image] .

Fini de jouer, si nous voulons utiliser notre maison, le mieux est qu'elle soit droite, sa base sur la ligne des X et si possible le centre du niveau en son intérieur car plus tard lorsque nous souhaiterons voir son intérieur le point de vue sera calculé à partir du centre.

Parce que c'est mieux et que plus tard nous voudrons créer une jolie entrée nous allons ajouter un cube par Object / Add Cube / Small. Ce cube se place, comme toutes les choses que vous ajouterez par la suite dans votre niveau, juste au centre de la fenêtre. Aussi si'il se place à l'intérieur de la maison et que notre vue 3D est en mode d'affichage "solid" nous ne le verrons pas tant qu'il ne sera pas à l'extérieur de la maison. Redimessionnez-le et tournez-le jusqu'à ce qu'il soit à la bonne taille.

En utilisant Mode / Walkthrough, en cliquant sur [image], ou en pressant la touche [W] (avec la fenêtre 3D d'activée), vous basculez en mode "déplacement" et à présent à l'intérieur de la fenêtre 3D vous pouvez à l'aide de la souris ou des touches de direction vous déplacer comme dans le niveau réel. Avec les touches Home] ou [End] vous vous déplacez comme si vous êtiez dans un ascenseur et en utilisant les touches [PgUp] ou [PgDn], vous changez l'angle de vue de la caméra. Si vous finissez par vous perdre ou si vous en avez tout simplement assez, pressez la touche [EChap] et à l'aide de View / Go to Center ou de la touche [Home] vous reviendrez au centre du niveau.

Vous avez essayé d'entrer dans la maison pour voir à quoi ressemblait l'intérieur et vous vous êtes rendu compte que tout était noir?

C'est simplement parce que notre maison est composée d'un seul bloc de construction virtuel que nous appelons justement un bloc (block). (cela peut-être du bois, de la roche,du béton ou du caoutchouc, nous le déterminerons plus tard à l'aide de texture). Les blocs sont les éléments de base, les briques qui seront les structures solides servant à fabriquer notre niveau. La forme de base d'un bloc est le cube que vous ajoutez à votre niveau par Add Cube puis Small, Medium ouLarge. Bien que différents des vrais, ils sont malgré tout utilisables. Mais ils peuvent également avoir la forme d'une maison ou d'une pyramide. Sous Add Primitives. vous trouverez Cylinders, Pyramids et les bois de charpente Lumbers aussi bien que différentes Spheres. En plus vous trouverez les Prefabs. Contrairement aux primitives qui sont consistuéses d'un seul bloc de forme prédéfinie, les préfabs sont des constructions complexes qui sont constitués de nombreux blocs et sauvés en tant que cartes (maps), ils constituent leur propre niveau et sont mis à notre disposition. Dès que nous serons un peu plus habiles avec WED, nous pourrons travailler les préfabs et les modifier ou créer nos propres préfabs et les stocker à la bonne place par Add Prefabs .

Pour transformer notre maison en bloc massif en une maison réelle avec 4 murs, un sol et un toit nous devons la creuser (hollow). Pour ce faire nous la sélectionnons et cliquons sur Edit / Hollow Block (ou pressez les touches Alt+H). Notre bloc sera creusé avec des murs d'épaisseur de 16 quants (vous pouvez modifier l'épaisseur des murs en choisissant File/Preferences et jouer avec le curseur hollow wall). Et voila:

...maintenant vous pouvez vous promener à l'intérieur!

- pause café!

précédent <<
>> suivant


WED Tutorial:First Room II

Premiere étape - Première pièce - Partie II

Prenons une minute pour regarder la fenêtre de projet à la gauche de l'écran. Si vous n'avez pas joué avec, elle devrait ressembler à ceci :

Par défaut la fenêtre d'objets est activée. Dans celle-ci on verra que tous les objets de notre niveau sont présentés sous forme d'arborescence. "Root" indique le début de l'arborescence, et l'endroit d'où votre niveau se développe. D'abord ceci comprend les blocs que nous ajoutons. Jusqu'à présent nous en avons deux, la maison et le cube. Cependant, en creusant le bloc de la maison nous l'avons divisé en bloc de plancher, toit et murs. Aussi notre maison se compose maintenant d'un groupe entier de blocs qui sont à l'intérieur du dossier group avec le + marqué près de lui.

Si votre niveau devient un " machin " énorme, et que vous voulez toujours savoir où trouver un bloc ou un groupe particulier, vous pouvez double-cliquer sur n'importe lequel de ces blocs ou éléments de groupe dans la fenêtre d'objets et ces objets seront choisis (tour rouge) dans les fenêtres de vue. Clic gauche sur des objets dans les fenêtres de vue mettra en gras l'article correspondant dans la fenêtre d'objets . Cliquer sur + près d'un dossier montrera tous les blocs et sous-groupes appartenant à ce groupe. Nous verrons plus tard que grouper et dégrouper sont des outils très utiles en éditant un niveau.

Le prochain onglet que nous pouvons ouvrir dans la fenêtre de projet est Views. Ici, clic droit sur le dossier Vews List vous permettra de sauvegarder de nombreuses positions de vues qui pourront alors être rappelées par un double clic. Une bonne manière de trouver des vues que vous voulez sauvegarder est d'employer le mode de mouvement de la caméra ou - bouton [image] sur la barre d'icône. Si vous n'aimez pas jouer avec la molette de la souris pour zoomer, il y a une icône avec une loupe afin que vous puissiez zoomer tout en tenant le bouton de souris. En outre, lorsque vous êtes en mode de mouvement de caméra, un carré rouge et un carré vert reliées par une ligne rouge apparaissent sur la carte. Le carré rouge est la caméra et le vert est la direction qu'elle pointe. En les déplaçant vous pouvez trouver rapidement le point de vue que vous voulez.

Avant que nous nous intéressions aux textures, jetons un oeil au dernier onglet : Resources, dans la fenêtre de projet. Il peut être nécessaire de cliquer sur la flêche droite pour visualiser cet onglet. Ici vous trouverez une autre arborescence pleine de dossiers de scripts et les fonctions qui appartiennent à votre niveau. Double cliquer sur une fonction de script la fera apparaître dans sa propre petite fenêtre. Mais nous n'en sommes pas aux fonctions pour l'instant, donc oublions cela pour l'instant.

L'option la plus utile dans notre fenêtre de projet est Textures. Notre niveau viendra à la vie une fois que nous aurons ajouté les murs plâtrés, les planchers carrelés, les tables en bois et une pléthore d'autres textures de surface à notre disposition. Puisque c'est un monde virtuel, nous n'avons pas besoin de travailler avec le mortier et le niveau. Nous pouvons créer toutes nos surfaces en employant l'infographie. 3d Game studio est fourni avec une multitude de textures dans une collection de "WAD". Si vous cliquiez à présent sur la fenêtre"default.wad" sous "object" et "texture" jusqu'ici vide, vous serez probablement déçu de ne voir qu'une texture. Cette texture est celle qui est employée si vous n'assignez aucune autre texture à vos blocs quand vous établissez votre niveau.

Oublions notre déception en chargeant plus de texures. Nous pouvons soit employer le menu de texture, Texture / Texture Manager / Add WAD, ou clic droit sur la texture par défaut et choisissez Texture Manager dans lequel vous cliquez sur Add WAD. Pour commencer nous choisissons "standard.wad" :

Vous pouvez réellement choisir parmi tous les wad affichés et faire vos propres Wad. Ils seront tous montrés sous l'onglet textures dans la fenêtre de projet. En cliquant sur une des barres de Wad, pour l'appeler, affiche toutes les textures de cette collection sous forme de vignette. Vous pouvez changer la taille de la fenêtre de vue (en l'étirant ou la réduisant) et également employer la barre d'ascenseur latérale pour le visionnement. Vous pouvez fermer la fenêtre en cliquant de nouveau sur la barre du Wad. Clic droit sur une texture ouvre un menu avec un certain nombre de choix. Parmi ces choix, vous pouvez éditer, extraire, renommer et faire un certain nombre d'autres choses à la texture. Vous pouvez également ajouter plus de textures à votre collection Wad. - Il est également possible, comme indiqué plus haut, de créer vos propres Wad. Pas besoin d'être un artiste professionnel. Vous pouvez utiliser des logiciels faits pour cela ou en télécharger sur Internet. Vous trouverez également des liens sur le site Conitec. Vous pouvez employer n'importe quelle image pour une texture aussi longtemps qu'elle est dans l'un des formats suivants : .PCX, .BMP ou .TGA.

Lorsque vous cliquez sur une texture dans votre collection Wad, elle apparaîtra dans la fenêtre intitulée "Textures":

Si vous voulez assigner cette texture, ou tout autre pour cette matière, à votre petite maison, choisissez la maison dans une des fenêtres d'édition puis double cliquez sur la texture désirée.
Vous pouvez également le faire en passant par Texture / Apply to Object ou clic droit sur la texture et sélectionnez Apply to Object.

Vous devz vous souvenir que notre maison se compose de plusieurs blocs différents. Vous avez probablement déjà établi que vous pouvez assigner une texture différente à chacun de ces blocs. Naturellement, votre maison sera plus réaliste si le plafond et le plancher ont une texture différente aux murs.

Pour choisir les différents blocs secondaires de notre maison, nous devons choisir notre maison puis cliquer sur [image] Cela correspond au bouton "niveau hierarchique bas" ou "scope down". Des objets disparaissent de notre carte (dans notre cas le bloc que nous mettons devant la maison) et vous pouvez vous concentrer sur l'article que vous avez choisi. Maintenant nous pouvons choisir les blocs secondaires :

Choisissez les blocs de toit et assignez une texture à chacun d'eux. Puis pendant que vous y êtes choisissez un joli plancher. Choisissez la vue texturée pour votre vue 3d et ainsi vous aurez une idée assez précise de ce que ça donnera. Une fois terminé cliquez sur [image] (niveau hiérarchique haut ou scope up). Vous pouvez également donner une texture au bloc que nous avons posé à l'extérieur de la maison.

- On se voit dans une minute!

précédent <<
>> suivant


WED Tutorial:First Room III

Premiere étape - Première pièce - Partie III

Vous avez commuté au mode de promenade (walkthrough), êtes allé voir autour de votre maison et maintenant vous avez l'impression d'être dans une niche à chien?

N'ayez crainte ! Avant que vous commenciez à vous maudire et reconstruire votre niveau depuis le début, rappelez-vous ce que nous avons dit au sujet de l'échelle du niveau. Si les briques ou les tableaux vous donnent l'impression que votre maison est trop grande, vous devez les redimensionner pour qu'ils conviennent. Par défaut un quant est équivalent à un pixel d'une texture. Nous avons construit notre première salle en considérant qu'un quant équivalait à 2 centimètres. Maintenant, si notre brique fait 20 centimètres dans la réalité, elle fera 10 quants dans notre monde virtuel (1 quant = 2cm, 10 quants = 20cm). Donc une brique sur notre texture doit faire 10 quants/ pixels de long.- Nous allons donc changer la taille de nos textures. Pour notre exemple nous avons "shinglewall" pour le toit, "woodfloor" pour le sol et "stoneblocks" pour les murs.

Commençons avec "stoneblocks". Clic droit sur la texture et sur Settings:

Nous allons redimensionner la partie horizontale ( x scale) et verticale (y scale) de notre texture. Vous pouvez soit entrer directement les valeurs à partir du clavier ou utiliser les petites flêches près des zones avec votre souris. Essayer en mettant 0.5 dans chaque champ. Cliquez sur OK ou pressez [Entrée]. Maintenant vos blocs sont réduits de moitié. Ces paramètres resteront jusqu'à ce que vous les changiez de nouveau. Sélectionnez la niche du chien (pardon je veux dire la maison), scope down et assignez la texture au 4 murs. Répétez la même procédure pour le sol et le toit.

Que se passe-t-il si je veux la même texture sur un autre bloc mais avec une échelle différente? Est-ce que les blocs que j'ai déjà texturé vont être remodifiés?

Non. Vous pouvez simplement changer la taille de votre texture et l'assigner à un autre bloc. C'est simple. Faites un essai. Sélectionnez votre deuxième bloc (si vous ne le trouvez pas peut-être devez-vous faire scope up), clic droit sur "stoneblocks", ajustez la taille et assignez lui.

Vous pouvez également jeter un oeil à l'intérieur. Beaucoup mieux!

Fantastique! Nous avons créé notre première pièce complète avec des textures et ressemble à une mignonne petite maison. Maintenant nous allons voir comme elle paraît avec le moteur A6! Tout d'abord nous avons besoin d'ajouter une position caméra. Allez dans le menu et cliquez sur Object/Add Position. La chose verte qui apparaît à l'écran est une caméra sur un trépied et représente la position virtuelle de nos yeux. Là où pointe la caméra sera ce que vous verrez au démarrage du niveau. Assurez vous que les pieds de la caméra pointent vers le sol si vous ne voulez pas voir votre monde la tête en bas et assurez vous qu'elle ne soit pas coincée dans un mur ou dans le sol.

Votre niveau devrait maintenant ressembler à ceci :

C'est une bonne idée de sauvegarder votre travail maintenant. Vous pouvez lui donner n'importe quel nom, comme FIRST_01, dans votre répertoire de travail (File / Save As). WED ajoute automatiquement l'extension de fichier .wmp. Le nom que vous donnez au niveau ne doit pas être plus long que 20 caractères et ne doit avoir d'espaces..

Maintenant il est temps de compiler notre niveau et d'aller voir à l'intérieur ! Cliquez sur File / Build ou [image] et vous obtiendrez cette magnifique fenêtre:

Le processus de compilation calcule une chose appelée "BSP tree" et converit notre fichier .wmp en un fichier .wmb. Avec des niveaux très grands et complexes la compilation peut prendre du temps, beaucoup de temps, beaucoup, beaucoup de temps, cela peut se compter en heures, en jours voire en semaines. En cochant Preview vos ombres ne seront pas terribles et votre niveau s'exécutera plus lentement mais la compilation sera beaucoup plus rapide. Donc pendant vos test utilisez le mode préview et lorsque votre niveau sera complètement terminé vous le compilerez une bonne fois pour toue sans le mode préview. Assurez-vous également que Level Map est coché et en cochantFly-thru vous pourrez survoler votre niveau une fois la compilation terminée.

Si votre niveau dépasse certaines valeurs- seuil vous recevrez des messages d'avertissement ou d'erreur quand vous compilez. Vous pouvez trouver ces valeurs dans Map Design. Une fois que votre niveau a fini la compilation (cela ne prendra pas longtemps pour un petit niveau tel que le nôtre) cliquez sur OK. Si vous n'aviez pas cliqué fly-thru vous devez cliquer sur [image] ou aller à File / Run Level.

Et maintenant ! Roulement de tambour...voici Mesdames et Messieurs, notre première pièce virtuelle ! Youpeeeeeeeeeee......:

Déplacez la caméra à travers le niveau, il n'est pas trop gros. Vous noterez qu'en utilisant la caméra vous pouvez passer à travers les murs. Ne vous inquiétez pas, cela ne se produira plus lorsque plus tard vous aurez mis un joueur.

Le moteur ne démarre pas ?

Si vous avez activé le rendu DirectX 8 pour la fenêtre 3D, (GXL_DX81 dans Preferences), avec certaines cartes 3D le moteur peut ne pas démarrer. Certaines cartes 3D ne supportent qu'une seule fenêtre 3D. Dans ce cas vous devez utiliser le mode de rendu 8 bits logiciel (GXL_BASE).

Si vous n'avez pas de cartes 3D du tout (ce qui est quand même dommage lorsqu'on utilise un logiciel 3D) ou si votre carte 3D ne supporte pas la résolution de votre bureau (ce qui est le cas de certaines vieilles cartes) vous recevrez un message d'erreur. Dans ce cas changez la résolution de votre bureau pour passer en profondeur de couleurs de 16 bits ou cochez no D3D à droite de walthrough dans la fenetre de compilation, pour pouvoir vous déplacer dans votre niveau en mode rendu logiciel. Certaines vieilles cartes nécessitent le mode dégradé (weak) pour le D3D (Option "-W3D")

précédent <<
>> suivant


WED Tutorial:Light & Shade I

Lumière et ombre - Partie I

Ok, nous avons réussi à créer notre première pièce. Elle est uniformément brillante et bien illuminée, ce qui est une bonne chose parce que si elle était sombre nous ne pourrions rien voir. Puisque jusqu'ici nous n'avons prêté aucune attention à notre éclairage, WED a automatiquement tout rendu lumineux pour nous. C'est très utile, mais 'est loin d'être parfait et conforme à ce que nous souhaitons. Plaçons donc quelques lumières et ajoutons une certaine atmosphère.

Nous allons tirer profit des dispositifs de l'éclairage du moteur A6. Nous placerons des sources lumineuses et paramèterons leurs couleurs et leurs étendues. Le moteur supporte aussi bien les sources lumineuses statiques que les sources lumineuses dynamiques. Des sources lumineuses dynamiques sont créées par un script quand le niveau est exécuté. Elles peuvent se déplacer, clignoter, changer de couleurs et ainsi de suite. Nous reviendrons à ces dernieres plus tard quand nous traiterons les scripts. Pour l'instant nous parlerons des sources lumineuses statiques. Celles-ci peuvent être placées dans votre niveau en utilisant WED. Elles paraissent mieux que les lumières dynamiques et peuvent jeter des ombres. Puisqu'elles n'ont aucune influence sur le taux d'affichage, vous pouvez en mettre autant que vous voulez dans tout votre niveau. Cependant, placez-les soigneusement car l'effet entier d'un niveau dépend de la bonne illumination.

Chargez votre premier niveau et ajoutez votre première source lumineuse en employant Object / Add Light. Elle apparaîtra sur votre carte sous la forme d'une ampoule. Essayez de la mettre au milieu de la salle près du plancher pour commencer :

Si vous exécutez maintenant le niveau et que votre pièce apparaît de la même façon qu'avant c'est vous avez oublié de compiler. Compilez donc le niveau et exécutez-le :

Là, où votre petite ampoule est localisée, vous trouvez une tache lumineuse sur le plancher. La lumière rayonne de ce point sphériquement à la limite de son étendue qui est de 300 quants. Au delà de cette étendue c'est toujours l'obscurité, naturellement.

Si à présent vous mettez votre ampoule plus haut, dans le tiers supérieur de la salle, cela ressemblera à ceci (n'oubliez pas de compiler) :

Évidemment ce n'est qu'une lumière et de l'ombre.

Quoi? Ce n'est pas vraiment ce que vous attendiez? Vous vouliez de l'atmosphère tonalités chaudes riches et ombres subtiles?

Nous verrons ce que nous pouvons faire. Car comme vous vous en doutez, pour que nous obtenions une ombre avons besoin non seulement d'une lumière, mais également d'un objet. Heureusement WED est fourni avec une gamme étendue d'objets préfabriqués pour notre utilisation, appelés les "préfabriqués." Pour l'instant, nous n'avons pas besoin de savoir faire ces derniers, nous allons juste en charger un et voir ce que nous pouvons faire avec lui. Allez à Object / Add Prefab et choisissez "archway2.wmp" sous building. Tournez-le de 90 degrés et placez-le sur le plancher contre le mur. Vous devrez également le redimensionner de sorte qu'il ressemble à ce qu'il est dans les images ci-dessous. Maintenant nous avons quelque chose que nous pouvons employer pour jeter des ombres.

Si vous ne pouvez pas vous retenir plus longtemps, allez-y, compilez le niveau et jetez un coup d'oeil :

Un petit mieux, mais les vrais bons jeux sont mieux que cela !

Éclairons-le vers le haut et débarassons-nous de ces bords dans les coins. Clic droit sur votre source lumineuse et ouvrez sa fenêtre de propriétés. Augmentez l'étendue (range) de la lumière de sa valeur par défaut 300 jusqu'à 400. Ceci devrait améliorer nos bords. Vous pouvez encore essayer de la faire plus lumineuse si vous le souhaitez. L'augmentation de l'étendue (range) augmente la zone centrale de la lumière.

Maintenant, ajoutez une autre petite ampoule. Ouvrez sa fenêtre de propriétés et cliquez sur la surface grise à côté des champs de la couleur (Red = rouge, Green = vert, Blue = bleu et128 pour chaque couleur donne la couleur gris). Choisissez le jaune. Essayez de lui donner une étendue (range) de 200 :

Ce n'est pas une ampoule très lumineuse mais puisque la lumière s'ajoute, nous allons en ajouter d'autres et les disposer tout autour. Sélectionnez la source lumineuse jaune et copiez-la par Edit / Copy ou [Ctrl.] + [C] suivi de Edit / Paste [Ctrl.] + [V]. Placez les ampoules sous les 3 voutes. Assurez-vous de ne pas placer vos ampoules coincées quelque part à l'intérieur d'une surface. Aucune ampoule n'éclairera une salle si elle est coincée dans un mur !

Si vous démarrez à présent votre niveau, il sera tout à fait prometteur. Les voûtes jettent des ombres, et par les croisillons il y a de la lumière qui tombe sur le plancher :

Bien, ceci est le B.A-BA. Continuons et apprenons certains des choses plus pointues !

- Repos!

précédent <<
>> suivant


WED Tutorial:Light & Shade II

Lumière et ombre - Partie II

Depuis nos premières expériences de peinture au jardin d'enfants nous savent qu'une maison sans cheminée n'est pas une vraie maison. Aussi construisons-en une ! Pour commencer nous faisons juste une colonne. Ajoutez un bloc par Object / Add Primitives / Cylinders et 8 sided. Redimensionnez-la à la bonne taille et déplacez-la dans une position appropriée, disons quelque part près de la voûte moyenne. Des cheminées sont habituellement faites en brique ou pierre. Vous pourriez donner à votre cheminée la même texture que vous avez donné aux murs (stoneblocks). Essayez de ne pas employer trop de différentes textures colorées - c'est une erreur souvent faite par des débutants. Et attention à la taille, elle a été paramétrée pour notre expérience avec le bloc dehors ! Changez-la encore en 0.5 par l'intermédiaire des Settings.

Ok, le cylindre de notre cheminée est en place. Compilez et exécutez le niveau. Joli, il y a notre colonne et, comme prévu, elle jette une ombre :

Quoique que, pas aussi joli que cela, c'est quoi ce côté très sombre?

Cela peut être corrigé facilement. Clic droit sur la texture stoneblocks texture et ouvrez Settings. Activez le drapeau Smooth (à condition que vous possédiez au moins la version commerciale) et assignez la texture de nouveau à votre colonne. Démarrez le niveau et jetez un oeil pour voir si cela vous plait.

Puisuque c'est joli et facile nous allons faire la même chose avec les toits en bois des voutes. Sélectionnez la voute et scope down. Cliquez sur le premier toit et allez à Object / Group / Add to (ou pressez juste [G]). La couleur du toit passera du rouge au brun. Faites la même chose pour les autres toits et n'oubliez pas les côtés!

Une fois que tout ce que vous voulez mettre en brun est fait nous allons une fois de plus vers Object / Group mais cette fois-ci nous cliquons sur Finish (ou [Ctrl]+[G]). A présent notre structure de toit devient un sous groupe à part entière et sera traité comme tout autre objet ou bloc:

Vous pouvez faire ce que vous voulez avec lui...

... mais pour l'instant nous assignerons une texture douce. Cliquez sur "woodflorhori", puis Settings et puis sur Smooth. Maintenant appliquez-la (apply) à votre groupe de toit sélectionné, niveau hierarchique haut (scope up) et c'est fait - que dites-vous de cela?

Retour dans le niveau, après compilation, et vous allez voir la différence!:

Avouez que ça a quand même meilleur allure.

Cependant, vous n'aimez toujours pas ces secteurs noirs et laids qui ne sont atteints par aucune lumière?

Dans le vrai monde il y a toujours une peu de lumière ambiante où aucune lumière ne brille directement. Nous pouvons réaliser cet effet en allant à File Map Properties . Puis cliquez sur Sun:

En employant Ambient vous pouvez ajuster l'éclairage ambient de votre niveau. Souvenz-vous, les paramètres que vous allez mettre affecteront le niveau entier. Si, par exemple, vous pensez qu'une lumière jaunâtre ferait bien dans notre pièce, vous devez vous demander si elle fera également bien dans les autres pièces même dehors. Vous devriez également vous assurer que votre lumière ambiante n'est pas trop lumineuse ou au contraire ne laisse pas des secteurs sombres. Comme vous pouvez voir sur l'image, j'ai choisi une lumière même faible en assignant une valeur de cinq dans chaque champ. Si vous voulez une ambience spéciale pour une partie particulière de votre niveau vous devrez créer le secteur en tant que carte séparée et puis l'inclure dans votre niveau principal.

Si vous démarrez maintenant le niveau, vous trouverez un minimum d'ambience même dans les coins les plus foncés et pouvez également identifier des choses et voir leurs textures.

Mais maintenant vous ne voulez pas juste une colonne, vous voulez la cheminée entière ?

Vous l'aurez .

- Mais après une pause pipi!
précédent <<
>> suivant


WED Tutorial:Light & Shade III

Lumière et ombre - Partie III

Pour transformer notre colonne en cheminée nous devons y faire un trou à l'intérieur. Faites encore un cylindre à huit côtés (en employant Object/Add Primitives/ Cylinders), Redimensionnez-le à la taille et la forme souhaitée et placez-le à sa bonne place. Ce bloc sera employé comme outil de poinçon. Cliquez sur Edit/ CSG Subtract avec l'objet selectionné et toute la partie où était le bloc sera maintenant découpée en tranches sans pitié. Ceci aura créé encore plus de surfaces qui doivent être texturées. Donnez-leur la texture "stoneblocks".

Si vous coupez la colonne en 2 morceaux, vous vous rendez bien compte que cela ne fera pas réaliste. Vous devez avoir des piliers ou laisser une partie du mur suffisante pour supporter la charge. Lorsque vous travailler sur de l'architecture virtuelle assurez-vous que tout ce que vous créez soit plausible.

Oups, vous n'avez pas coupé au bon endroit?

Pas de panique, vous pouvez toujours remonter ou abaisser toute la cheminée pour que l'ouverture soit à l bonne hauteur.

En réalité une cheminée est creuse à l'intérieur. Cependant, à moins que vous n'ayez besoin que votre joueur puisse s'élever vers l'intérieur de la cheminée ou quelque chose du même ordre, nous vraiment n'avons pas besoin qu'elle soit creuse. En outre une telle découpe génèrerait de nombreuses sections qui augmenteraient notre temps de rendu.

Maintenant pour le feu allez à Object/ Add Model et chargez flame.mdl. En fait c'est une torche, mais n'étant pas à cours d'idées nous allons tricher et l'utilier comme flamme. Redimensionnez votre torche de sorte que la flamme soit à la bonne taille et placez-la de sorte que seule la flamme soit visible dans la cheminée. Si vous aimez, vous pouvez ajouter plusieurs de ces modèles ainsi vous aurez plus de flammes. Si nous voulions une lumière clignotante pour notre feu nous devrions écrire un script. Ceci viendra plus tard. Pour l'instant nous allons ajouter juste une lumière standard.

Le feu a besoin de carburant. Vous pouvez faire quelques morceaux de bois en utilisant la primitive "bois de charpente" ("lumber"). Redimensionnez, tournez et donnez-lui une texture bois. Puis placez les dans la cheminée.

Une autre possibilité consiste à utiliser firplc3.wmp à partir de la liste "fireplaces". Niveau hiérarchique bas [image] dessus et grouper les 3 morceaux de bois comme nous l'avons fait avec les toits en utilisant Object / Group / Add To ou pressez [G].

Dés que ces 3 morceaux sont surlignés en orange/brun vous pouvez terminer le groupe avec Finish Group (Ctrl + [G]). Déplacez le bois en dehors du reste du préfabriqué et posez-le dans votre propre cheminée. Vous pouvez les dégrouper ( Ungroup) et les modifier ou /et les déplacer individuellement si vous le souhaitez. C'est une bonne idée de les regrouper une fois que vous avez fini juste pour que les choses soient bien en ordre. Sélectionnez le reste du préfabriqué (utilisez le mode [image]) et effacez le en utilisant la touche [Suppr].

Maintenant niveau hiérarchique haut [image] de nouveau et ajustez les pièces de bois juqu'à ce qu'elles s'adaptent parfaitement dans la cheminée.

Puisque ce chapitre est consacré à l'éclairage, revenons à nos moutons et positionnez une petite ampoule dans la cheminée, clic droit sur elle et sélectionnez Properties. Donnez une étendue de 400. Pour une couleur appropriée à un feu cliquez sur le panneau de couleur et choisissez alors Define Custom Colors:

Puis nous choisisson sun orange brillant pour notre feu et cliquons sur OK.

Et pour avoir une atmosphère encore plus réalsite, nous éteignons notre lampe grise du plafond (en utilisant simplement la touche [Suppr]) et donnons à notre ampoule du milieu une étendue plus élevée comme 300.

Compilez et soyez épaté:

Cela s'avére être très bien, vous ne pensez pas ? Mais on commence à se sentir à ici, aussi dans le prochain chapitre nous sortirons . Je vous rencontrerez là-bas.

précédent <<
>> suivant


WED Tutorial:Outside World I

Monde extérieur - Partie I

A présent nous avons l'intention d'abandooner notre petit intérieur douillet pour aller dehors. Ceci étant dit, pour l'instant, ce n'est pas une très bonne idée puisqu'il n'y a rien qu'un grand vide noir en dehors de nos 4 murs. Aussi, avant toute chose, nous devons créer notre monde avec un sol pour pouvoir marcher dessus, un soleil pour nous éclairer et un ciel au dessus de notre tête.

Pour commencer, ajoutez un nouveau bloc : Object / Add Cube / Large. Agrandissez le suffisemment pour enfermer la totalité de votre monde. Vous pouvez le faire de 50 000 quants de large dans chaque direction, sachant que pour notre exemple 3 ou 4 milliers suffiront. Assurez-vous que notre maison soit bien à l'intérieur et que la partie supérieure soit bien au dessus de notre cheminée..

A présent Edit/ Hollow Block, et nous obtenons un grand espace vide pour poser notre monde à l'intérieur. Déplacez cette énorme bloc de façon à ce que notre maison repose sur sa partie basse - elle serait ridicule si elle flottait entre ciel et terre. C'est mieux si la base de la maison et la base de la grande boite sont fusionnées plutôt que d'avoir un léger espace entre les 2:

S'il y avait un léger espace, le moteur détecterait un plan double ("duplicate planes") et tenterez de faire son rendu en utilisant la haute précison ("high precision") ce qui prendrait un bon moment supplémentaire.

Après cela, nous avons besoin, bien entendu, de textures. Pour le ciel, vous pouvez assigner n'importe laquelle des textures fournies avec le wad standard qui commence par le mot "sky," mais c'est seulement du provisoire utile pour le mode "fly through". Plus tard nous en ferons un beaucoup mieux en utilisant un script. Pour le moment nous utiliserons la texture "skycloud" qui est incluse dans tutor.wad, qui est fournie avec le tutorial et qui peut être ajoutée au wad standard par Texture / Texture Manager / Add Wad .

Puisque le ciel rempli la totalité du bloc à l'exception du sol, il est plus simple d'assigner la texture ciel à l'ensemble du bloc, puis " scope down" et de donner une texture au sol. Vous pouvez utiliser "floorts1" qui est inclu dans le fichier tutor.wad si vous voulez.

Vous êtes allé de nouveau et avez découvert que tout était noir à l'exception du ciel?

C'est tout simplement parce que nous avons un soleil brillant noir. Ce serait idéal si nous utilisions un niveau de science fiction mais dans notre cas ce n'est pas approprié. Allons dans File/ Map Properties/ Sun:

Cette fenêtre nous est déjà familière. Nous l'avons déjà utilisée pour nos valeurs d'ambience Vous avez noté que toutes les valeurs concernant le soleil (sun) sont à 0 ce qui donne du noir. Cliquez sur le pavé de couleur correspondant à la couleur du soleil et choisissez une couleur. Pensez soigneusement à l'atmosphère que vous souhaitez donner à votre niveau. Si c'est le début d'après midi vous pourriez vouloir mettre une lumière blanche lumineuse, si vous recherchez un coucher de soleil sur Capri peut-être qu'une lumière rougeatre serait plus appropriée.

Essayez différentes valeurs. J'ai donné un soleil jaune correspondant à l'après midi. Puisque nous sommes l'après midi le soleil doit se trouver haut dans le ciel. Pour cela nous devons utiliser les paramètres Sun Azimuth et Sun Elevation. Si nous voulons que le soleil se déplace dans notre ciel et un changement de temps nous devons utiliser un script, mais pour un moment donné de la journée nous pouvons utiliser les paramètres ici.

Si vous ne savez pas à quoi correspond l'azimuth, je vais vous l'expliquer. C'est l'angle du soleil. Ceci déterminera d'où le soleil luit et la façon dont seront projetées les ombres. Ajustez les nombres pour trouver un azimuth qui vous convienne.

Jetez un œil à votre fenêtre de vue supérieure et regardez-le comme si c'étaient une carte. Le nord est au dessus, l'est vers la droite, le sud en bas et vers la gauche se trouve l'ouest sauvage. Vous vous trouvez au centre. Puisque le soleil se lève à l'est, une valeur nulle pour votre azimut mettra le soleil à la droite de votre carte :

Si vous voulez que le soleil brille du nord vous saisissez 90. À 180 il brille de l'ouest, et il se tient dans le sud à 270. La valeur s'incrémente jusqu'à 360 où elle est de retour dans l'est. Maintenant, il est vrai que le soleil ne brille jamais du nord, mais nous ne sommes pas trop inquiétés par notre boussole ici. La chose importante est d'avoir nos ombres qui tombent dans la direction que nous voulons. La chose importante à se rappeler est que votre azimut a une étendue de 0 à 360 et tourne dans un sens anti-horaire. J'ai choisi une valeur de 255 pour ce niveau.

Maintenant changeons l'altitude de notre soleil. Ici nous traitons de l'angle formé par la lumière du soleil frappant la terre. Comme nous pouvons le voir tous les jours, le soleil se lève avec un angle très aigu causant de longues ombres, puis il s'élève jusqu'à ce que ce soit presque au dessus de notre tête et les ombres sont très courtes. Enfin le soleil voyage à travers le ciel jusqu'à disparaître, générant de nouveau de longues ombres. Nous avons seulement besoin d'un demi-cercle de 180 degrés pour décrire l'angle d'incidence du soleil pendant le jour. Zéro est totalement aigu, qui nous donne une longue ombre ; 90 correspond au soleil à son zénith, qui ne nous donne aucune ombre excepté sous des objets.

Ici vous pouvez voir comment sont les ombres en fonction de différentes altitudes dans le niveau :

Bien, maintenant vous avez placé vos paramètres du soleil !

- déjeuner !

précédent <<
>> suivant


WED Tutorial:Outside World II

Monde extérieur - Partie II

Maintenant dans l'éclat de la lumière du soleil, vous pouvez voir des choses étranges à l'horizon de votre ciel?

Chaque dernier Pixel est étiré comme une bande élastique et il y a les bords noirs à l'horizon. Plus tard, nous emploierons un fond plus élégant appelé "scene map." Pour le moment nous ne sommes pas assez avancés pour cela, aussi nous nous contenterons d'essayer de couvrir le plus mauvais avec un simple mur.

Créez un autre cube, agrandissez-le et creusez-le puis niveau hiérarchique bas et supprimez la partie basse et la partie haute. Donnez-lui une texture, j'utilise "plank". Maintenant nous allons donner un peu de cachet à la scène en utilisant une tour préfabriquée : Add Prefab / buildings/ "tower3." Redimmensionnez la tour jusqu'à ce qu'elle soit de la bonne taille par rapport au mur. Faites plusieurs tours par copier/coller (Edit/ Copy et Edit/ Paste ou [Ctrl] + [C] et [Ctrl] + [V]). Vous pouvez également utiliser une méthode spécifique à WED: en mode déplacement (move) et avec la tour de sélectionnée, maintenez appuyée la touche [shift] key et déplacez la souris. Voilà, vous avez une copie de la tour et il ne vous reste plus qu'à la positionner au bon endroit. Faites attention lors de la duplication à ce que les tours ne se superposent pas par inadvertance.

Peu importe la méthode de copie, à la fin vous devriez avoir une tour placée à chacun des quatre coins de notre mur. Vous voulez probablement jeter un coup d'oeil à votre travail. Avant que vous commenciez le niveau, essayez de placer caméra dehors avant la compilation. De cette façon vous n'aurez pas à traverser les murs quand le niveau commencera.

Hmn, ces ombres sont un peu trop pointues et noires pour moi. Que faire ? Augmentez la valeur ambiante ? Faites attention ! Rappelez-vous que changer la valeur d'ambience affectera votre niveau entier et vous pourriez gâcher votre éclairage à l'intérieur de la maison.

Que diriez-vous de d'ajouter quelques lumières supplémentaires à la place ? Puisque les ampoules elles-mêmes sont invisibles, les joueurs ne verront pas notre petite fraude. Allez à Object/ Add Light. Maintenez l'ampoule sélectionnée et clic pour obtenir sa fenêtre de propriétés. Placez une couleur brune foncée et une étendue légère de 1000 :

Dupliquez cette lumière jusqu'à ce que vous ayez quatre d'entre elles et positionnez-les de sorte qu'elles éclaircissent les secteurs ombragés :

N'hesitez pas à faire différents essais pour trouver les bonnes positions. Si vous voulez voir à quoi ressemble votre niveau sans avoir à recompiler intégralement le niveau à chaque fois, vous pouvez cocher l'option "Lights" dans la fenêtre de compilation:

Fait?

C'est mieux!

- Que diriez-vous de boire un thé?

précédent <<
>> suivant


WED Tutorial:Outside World III

Monde extérieur - Partie III

Ce qui me tracasse à présent c'est le cube qui se trouve devant la maison. Bien entendu nous pourrions le sélectionner et le faire disparaître [Del]. Mais pourquoi tant de cruauté? L'idéal serait que nous le retravaillons pour le transformer en une zone d'entrée. Que diriez-vous de faire un mur en pente?

Sélectionnez tout d'abord le bloc,puis passez en mode "déplacement de bords" en utilisant Mode/ Edge Move ou en cliquant sur [image]. Notre cube se tâche brusquement de points jaunes. Ils représentent les bords de notre bloc qui peuvent être saisis et déplacés avec la souris.

Mais attendez! C'est quoi ce message?:

Les blocs concaves résultent d'un mauvais déplacement de bords ou de sommets. Dans ce cas le moteur devrait "plier" la face d'un bloc pour pouvoir le montrer. Puisqu'on ne permet pas les polygones coudés, WED refuse de les accepter - n'importe comment il est inutile de s'arracher les cheveux. Vous pouvez décider d'être plus têtu que le moteur en décidant d'employer "ignorez". Mais si vous forcez les blocs concaves ou coudés vous aurez des problèmes lors de la compilation, ou au minimum plus tard dans le niveau.

Revenons à nos moutons, cliquez OK et essayons de nouveau. Cependant cette fois, nous allons mieux nous y prendre. Recherchez les flèches croisées sur la barre d'icône : . C'est le paramétrage par défaut des directions dans lesquelles il est possible de déplacer un objet, un bord, une face ou un sommet. Cliquez dessus et changerz le en [image] . A partir de maitenant le déplacement vertical estinterdit à l'intérieur de toutes les fenêtres et vous pouvez manipuler vos objets dans la direction horizontale sans avoir besoin d'une main régulière. Cliquez de nouveau sur l'icône et changez-le en [image] pour l'édition verticale. Un nouveauclic et vous revenez au paramétrage par défaut.

Ce dont nous avons besoin pour l'instant c'est d'un déplacement horizontal aussi nous revenons à [image] . Dans la vue arrière (back) vous tirez le point droit inférieur vers la droite:

Puis vous saisissez le bord du début de la pente et vous le légèrement vers la gauche:

Vous pouvez le faire aussi bien avec la vue de dessus qu'avec la vue arrière, ça n'a aucune importance. De plus vous pouvez tirer le bloc déjà biseauté plus loin dans toutes les deux fenêtres sans recevoir un quelconque message méchant.

Ok, nous avons la pente, mais ce n'est pas encore tout à fait ce que nous voulons. Nous voulons que les murs des deux côtés soient plus haut que la rampe elle-même.
Chargez un nouveau bloc, placez-le sur la pente et déformez-le de sorte qu'il soit un peu plus étroit et juste de la même longueur que la rampe. Placez-le de sorte qu'il couvre ce que nous voulons couper au loin. Arrêtez ! Ne cliquez pas CSG Substract tout de suite !

Non seulement nos petits murs devraient être sur une pente, mais également le passage entre. Choisissez votre bloc de poinçon et tournez-le. Vous noterez qu'il n'est pas très facile d'obtenir une position fine en utilisant le mode rotate ( [image] ). Clic droit sur le bloc sélectionné et ouvrez sa fenêtre de propriétés (properties):

Ici nous pouvons tourner notre bloc en employant les flèches à côté des champs de nombre sous "Rotate."

Vous vous demandez pourquoi, dés que vous relâchez les flèches, l'affichage revient à zéro?

Bien, l'explication est logique. Le bloc fraîchement tourné a été transformé et ainsi sa position
a de nouveau une valeur de zéro. Voyez-vous ?

Maintenant nous devons ajuster le bord supérieur de notre pente pour correspondre au plancher de la maison et pour mesurer le bloc de sorte qu'il laisse un mur des deux côtés. Avant de percer votre trou, ce serait une bonne idée de donner aux deux blocs (la pente et le poinçon) la même texture. Le bloc qui fait le poinçon laissant sa texture sur les surfaces coupées :

Non, ne coupez toujours pas !

Si vous utilisiez CSG Subtract maintenant, vous avez toutes les chances de faire également un trou dans le mur de la maison et/ou dans le sol Ce serait une véritable catastrophe et augmenterait le temps de rendu. Avant de couper, déplacez l'objet vers le haut dans le ciel. Groupez les 2 blocs avec Object/ Group/ Add To et Finish. Déplacez les 2 parties ajustées vers un endroit où vous ne risquez pas de coupez quelque chose qu'il y aurait autour. Dégroupez les blocs avec Object/ Group/ Ungroup et sélectionnez le bloc servant de poinçon qui passe en rouge. Maintenant vous pouvez percer votre bloc Edit/ CSG Subtract... et supprimer le bloc servant de poinçon.

Bien, mais je n'aime pas trop ces bords pointus. Chargez un autre bloc (ne pas oubliez de lui assigner la texture) et coupez les:

Pour finir, déplacer notre nouvelle surface d'entrée à la place qui lui revient:

Compilez et observez :

N'êtes-vous fatigué de toujours passer par le mur ? Que diriez-vous de faire une sorte d'entrée?

Bien, le prochain chapitre traitera de la façon de faire un trou dans le mur, ainsi que de faire la porte qui va bien avec !

précédent <<
>> suivant


WED Tutorial:Breakthrough I

Une percée élégante - Partie I

Avant de poursuivre, voici un truc : neutralisez les grands objets comme la boîte de ciel ou la barrière. C'est non seulement pénible de devoir cliquer des dizaines de fois pour sélectionner l'objet désiré mais vous risquez en plus de déplacer par idnavertance et ne pas savoir les remettre à la bonne place.

Comment procédons-nous pour cela?

Sélectionnez la boîte de ciel qui se retrouve en rouge. Regardez ensuite dans l'onglet Objects de la fenêtre project:

Clic droit sur le groupe correspondant à notre ciel ou notre barrière. Sélectionnez Render Style, puis d'ici, Disabled. le contenu du répertoire du groupe sélectionné passe en grisé et l'objet dans la fenêtre de travail est maintenant vert.

Les objets traités de cette façon ne peuvent plus être bougés ou sélectionné. Vous allez donc pouvoir travailler sur votre projet sans vous inquiter d'eux. Vous pouvez à tout moment les remettre normalement en sélectionnant Render Style et en cliquant de nouveau sur disable.

Cette méthode est bien pratique si vous travaillez sur une petite zone à l'intérieur d'un grand niveau, comme c'est notre cas à présent.

Ok, vous avez invalidé la boîte de ciel et la barrière pour l'instant. Que désirez-vous vraiment comme entrée! Je reconnais qu'une maison dans laquelle on ne peut pas entrer n'est pas très réaliste. Aussi nous allons percer un mur afin de pouvoir poser une porte par la suite si nous le désirons.

Comme pour l'exercice sur l'éclairage nous plaçons archway2 dans notre niveau. Si nous nous contentions maintenant de faire un simple trou dans le mur, ça ne serait pas terrible, ce dont nous avons besoin c'est d'un passage en forme d'arche. Pour réaliser cela nous avons besoin d'un poinçon en forme d'arche. Mais il faut faire attention à ce que nous faisons avec. Si nous réalisons un trou de la mauvaise taille dans notre mur, il sera très difficile de le corriger par la suite - nous ne pouvons pas redimensionner les trous.

Comment allons nous créer notre bloc poinçon?

Pour commencer nous avons besoin d'un bloc. Chargez un petit cube. Puisque nous voulons qu'il ressemble à archway2, placez le devant et redimensionnez le de sorte qu'il s'adapte parfaitement autour des bords droits et qu'il soit assez haut pour atteindre le dessus de la courbe sur le haut.

Zut! La pente de l'entrée est dans votre chemin et fait que vous attrapez archway 2 à la place du cube?

Déplacez l'entrée vers un endroit où elle ne sera pas dans votre chemin. Avec l'aide de [image] déplacez l'arche plus loin à l'intérieur de la maison. Vous ne voulez pas le couper par accident aussi vous pouvez le désactiver (vous avez déjà oublié?). Maintenant nous avons besoin d'un outil pour couper notre cube en voûte. Chargez un autre cube et dimensionnez-le de sorte qu'il recouvre la longueur et la largeur de notre premier.

Déplacez les deux blocs vers la droite, en s'assurant que vous êtes toujours en mode de mouvement horizontal, de sorte qu'ils soient devant la maison. Assurez-vous qu'ils soient assez loin afin de ne pas poiçonner accidentellement poinçonner des trous dans le mur :

Génial ! Maintenant nous sommes prêts à faire notre bloc de poinçon de passage arqué. Pour ceci nous avons seulement besoin de la fenêtre de vue de côté, aussi cliquez dessus [image] afin qu'elle occupe toute la surface de travail. Zoomer votre vue jusqu'à ammener l'objet au milieu de votre zone de travail. .

Une chose utile au sujet de la neutralisation d' archway2 c'est qu'il est très facile de voir les autres blocs avec leur contour vert.

Placez le bloc de découpage de telle façon qu'il soit à l'intérieur-dessus de la voûte et couvre le notre bloc supérieur à couper. Cliquez sur Edit / CSG Subtract

Truc: Si vous n'aimez pas que votre objet se déplace par à coup, il suffit dinvalider l'aimant en le décochant [image] .

Maintenant nous tournons notre bloc actif, en passant en mode rotate [image] ou en faisant des ajustements dans la fenêtre de propriétés comme nous l'avons fait pour notre pente. Cette fois ajustent le champ au milieu du panneau de rotation.

Peu importe la manière que vous décidez d'utiliser. La chose principale est que le bord intérieur de votre bloc suive la ligne verte de la voûte. Vous noterez que seulement la rotation n'est pas assez, vous devez également déplacer le bloc jusqu'à ce qu'il aille.

- puis coupez !

Vous faites cela des deux côtés naturellement.

J'allais bien, et alors ceci s'est produit. Qu'est-ce qui a mal tourné ? :

Naturellement il n'y a aucune petite flèche rose dans votre WED et la nouvelle ligne blanche a été soulignée par moi. Mais que s'est-il produit ? Vous avez essayé de couper une bosselure concave (flèches roses) en bloc. Le moteur n'aime pas aussi il a divisé le bloc. Malheureusement nous ne pouvons pas employer un groupe comme outil de poinçon, aussi ceci ne suffira pas du tout.

Que faire ?

Tout d'abord un Undo serait une bonne idée. Puis nous déplaçons et tournons notre bloc en faisant en sorte de ne pas produire un bloc concave. .

Sortez du plancher ! Assurez-vous que vous ne creusez pas un trou avec votre bloc de découpage.

Si vous êtes un perfectionniste, vous pouvez couper petit à petit jusqu'à ce que vous atteigniez la perpendiculaire, bien qu'un résultat approximatif nous convienne parfaitement :

Notre bloc de voûte-poinçon n'est-il pas simplement merveilleux ? Maintenant il faut lui donner la bonne texture. Pour éviter d'avoir la texture par défaut (les pierres carrées grises) plus tard, nous assignons à notre bloc la même texture que celle que le mur a déjà.

Maintenant nous sommes prêts pour l'action ! Déplacez le bloc là où vous voulez votre passage :

- puis coupez! (Edit / CSG Subtract)

Votre mur pourrait être morcelé un peu, mais à la condition de ne pas déplacer certaines de ces parties ça ne pose aucun problème. De toute façon, nous n'utiliserons pas le mur comme objet de coupe.

Stop, ne pas effacer! Un tel bloc peut certainement encore nous servir.

- Je ferai bien une petite sieste moi, pas vous?

précédent <<
>> suivant


WED Tutorial:Breakthrough II

Une percée élégante - Partie II

Par précaution nous sauvegarderons notre bloc comme préfabriqué afin de pouvoir le rendre disponible pour la suite:

Nous le sélectionnons et allons à Object / Save Prefab:

Une fenêtre s'ouvrira montrant le contenu de votre répertoire de travail. Donnez un nom à votre objet et cliquez sur Save. Maintenant à chaque fois que vous voudrez charger ce bloc dans votre niveau pour pourrez le trouver par Object / Load Prefab.

Vous pouvez également sauver d'autres préfabriqués que vous avez faits de cette manière. Par exemple, vous pourriez sauvegarder votre petite maison sous buildings ou créer votre propre répertoire qui contiendra vos propres préfabriqués.Puis à chaque fois que vous en aurez besoin, vous les trouverez avec les autres préfabriqués:

Bien entendu vous pouvez utiliser votre préfabriqué pour ce que vous voulez. Il n'a pas besoin d'être obligatoirement un poinçon. Vous pourriez l'agrandir et le creuser pour le transformer en une jolie cabane à outils!

Essayez. N'oubliez pas de lui faire une entrée. Mettez l'entrée face au soleil de façon à ce que la lumière puisse pénétrer à l'intérieur. Placez également une lumière brun foncé (106/ 92/ 77) à l'intérieur avec une étendue de 100:

Notre préfabriqué pourrait être également une niche ou nous pourrions la transformer en petite dépendance ou ce que vous voulez...

Finallement, nous replaçons notre archway2 dans sa positioninitiale. Puisuqe la première fois nous ne l'avons pas fait avec précaution, nous allons à présent le racourcir légèrement sur le plan horizontalpour qu'il s'adapte parfaitement dans notre entrée-arche. Ensuite nous attrapons notre zone d'entrée qui doit flotter queque part dans le niveau et nous le mettons devant notre percée. Déplacez-le et redimensionnez-le jusqu'à ce qu'il s'adapte parfaitement:

Puis compilz e [image]! Pendant que vous patientez, vous pouvez vous ronger les ongles....

.... et voila, le but de notre leçon!

Vous trouvez tout ceci un peu maladroit et pas très réaliste ?

Nous traiterons plus en détail certains points dans le prochain chapitre quand nous traiterons de la gestion de base des textures.

précédent <<
>> suivant


WED Tutorial:Basic Texturing I

La texturisation de base Partie I

Tous les objets à l'intérieur de notre niveau ont non seulement besoin de bonnes textures pour paraître réalistes mais il est également nécessaire qu'elles soient bien appliquées. Souvent, c'est le petit détail qui fait toute la différence. Vous devrez vous appliquer jusqu'au bout, tenir compte de l'éclairage... Si vous sous-estimez l'importance des textures votre niveau ne rendra jamais une ambience réaliste.

C'est pourquoi nous allons apprendre comment donner une touche de réalité à notre monde virtuel. Jetez un coup d'oeil à votre maison, elle ressemeble avant tout à un bloc. Dans une vraie maison le toit ne s'arrête pas pile-poil sur les murs, il dépasse légèrement et génère des ombres. Nous allons commencer par ceci.

Sélectionnez la maison et niveau hiérarchique bas [image]. Faites bien attention d'être toujours dans le mode sélection [image] pour naviguer parmi les différentes couches. Autrement vous ne vous en prendrez qu'à vous-même si vous déplacez ou redimenssionnez des parties de la maison, encore et encore par accident.

Maintenant nous avons isolé notre maison et nous sommes en mesure de travailler sur les détails. Intéressons-nous au toit.

Groupez les moitiés ensemble( Object / Add To et Finish comme d'habitude). Maintenant redimenssionnez le toit sur sa longueur et sa largeur et placez-le de sorte qu'il repose sur les murs latéraux. C'est mieux s'il pénétre un peu dans les murs plutôt que de laisser un espace.

Voilà qui parait simple, n'est-ce pas? Remontons à notre niveau le plus élevé et regardons notre nouveau toit:

Il paraît mieux mais il reste quelque chose de pas terrible?

Les textures! Elles n'ont pas suivi la direction de notre objet. Je ne connais aucun pignon au monde qui ressemble à celui-ci!

Les textures! Elles n'ont pas suivi la direction de notre objet. Je ne connais aucun pignon au monde qui ressemble à celui-ci.

Nous voulons manipuler la texture de chacune des surfaces de notre objet. Sous l'onglet surface et texture vous trouverez toutes les surfaces individuellement et les textures qui leur sont appliquées:

Nous pouvons non seulement appliquer individuellement des textures sur chaque surface mais nous pouvons également changer les propriétés de chacune d'elles. "Surface #1 of 6" indique que notre bloc a 6 surfaces et que nous allons à présent traiter la première. Cliquez sur les flèches gauche et droite pour faire apparaître cycliquement les autres surfaces. La surface actuellement sélectionnée est en surbrillance jaune dans les fenêtres de l'éditeur.

On peut lire le nom de la texture, shinglewall; sa taille, 256 x 256 pixels, et qu'elle a une profondeur de couleur de 16 bits. Il y a également une représentation visuelle de la texture.

A cet instant ce serait une bonne idée de passer en mode texturé View / Textured ([F7]). Les grandes surfaces de notre toit sont biens, nous n'avons donc pas besoin d'y retoucher. Ce que nous voulons c'est travailler sur les textures des côtés. Utilisez les flèches jusqu'à trouver la face avant. Elle est en surbrillance jaune.

Commençons par tourner notre texture en utilisant "angle" jusqu'à ce qu'il apparaisse dans l'alignement du toit. Pour la partie droite de mon toit c'est un angle de 338.00.Ce que l'on peut voir sur l'image ci-dessous:

Bien, maintenant la direction est correcte. Nos bardeaux ne pas pas très alignés, nous allons remédier à cela!

Redimensionnez votre texture et agrandissez-la verticalement sur l'axe des y y scale (y-axis) puis déplacez-la le long de l'axe y (y-offset) jusqu'à ce qu'elle soit ajustée:

Souvenez-vous des valeurs obtenues car il faudra appliquer les mêmes au côté opposé

C'est fait? Excellent! Maintenant la même chose avec la partie gauche du toit.

Nous devons toujours travailler sur les surfaces des côtés:

L'angle de 0 est correcet, mais le redimensionnement et le glissement n'est pas le même, aussi voici lmes valeurs qui sont de 7 poury offset et 0.600 poury scale:

La bonne nouvelle c'est qu'une fois que vous avez alignés les textures sur toutes les surfaces de la moitié de votre toit, l'autre moitié devient beaucoup plus facile puisqu'il suffit de recopier les valeurs et ce sera fait!:

...Et voici le résultat, ça valait la peine!

- Vous servez des esquimaux?!

précédent <<
>> suivant


WED Tutorial:Basic Texturing II

La texturisation de base Partie II

Le toit n'était que le début. Allons voir la zone d'entrée...on ne peut vraiment pas la laisser comme ça:

Qu'est-ce que vous attendez? Sélectionnez l'objet, scope down et utilisez les flèches dans l'onglet tab de la fenêtre des propriétés pour sélectionner la grande surface du milieu (cadre jaune). Vérifiez que c'est bien la surface du dessus et non celle du dessous qui n'étant pas bvisible ne nous intéresse pas. Tournez la texture de cette surface ou tapez directement l'angle de rotation désiré dans le champ "angle"(dans notre cas 90 est la bonne valeur).

Maintenant remontons vers les bords. Déplacez la texture en utilisant les flèches de x offset et y offset afin que le résultat final donne l'impression que les ouvriers ont fait du bon travail.

Vous avez probablement déjà noté que ce bloc n'a pas six, mais sept surfaces. Il y a un petit morceau plat à l'extrémité supérieure. Regardons-le de plus près.

Assurez vous qu'il soit sélectionné puis utilisez les outils de rotation (angle) et de décalage (x et y offset) jusqu'à ce qu'il se fonde dans le reste du bloc.

Occupons-nous du mur opposé..

Sélectionnez-en un puis scope down pour ne voir que lui (n'oubliez pas d'être en mode sélection [image]).

Une fois encore il faut utilisez les outils de rotation et de décalage pour que l'apparence soit bonne. Commencez par la plus grande surface en premier.

.

Tournez-vous ensuite vers la partie plate. Ici vous pouvez vous épargner de jouer du violon pour obtenir un alignement exact. Puisque c'est juste une prolongation de la texture déjà ajustée de la pente, il est plus simple de copier ces valeurs dans les champs appropriés:

Comme vous le supposiez certainement, les choses se compliquent quand nous en arrivons aux côtés. Car les graphiques je joignent perpendiculairement (90°) et 45°. Deux options s'ouvrent à vous, soit ne rien faire soit essayer d'ajuster du mieux possible les textures. La bonne nouvelle c'est que probablement personne n'y fera attention.

Maintenant répétez toute la procédure sur l'autre côté du mur (scope up, sélectionnez l'autre côté, scope down pour travailler sur lui. Démarrez avec la partie supérieure et votre bloc devrait ressembler à cette image une fois que vous aurez terminé!

- Aérez la pièce!

précédent <<
>> suivant


WED Tutorial:Basic Texturing III

La texturisation de base Partie III

Fantastique, ! Nous avons un toit superbe et une jolie entrée.

Mais il y a quelque chose qui ne va pas bien avec notre cabane

C'est vrai qu'on ne voit pas une telle cabane à outils tous les jours. S'il pleut le toit sera vite imbibé et ne tiendra pas longtemps.

Nous allons donc travailler dessus. Vous connaissez à présent la méthode. Commencez par l'intérieur et tournez les textures intérieures du sol et du plafond de 90°. Puis nous clouerons un feuillard sur le toit pour le rendre étanche.

Vous avez probablement déjà deviné qu'on pouvait appliquer une nouvelle texture sur une surface simplement en cliquant dessus. Je vous recommande d'utiliser metalrivet2. Elle est complète avec les rivets. Comme moi, que diriez-vous de redimenssionner la texture de à 0.75 et de la décaler un peu pour la ranger vers le haut.

L'image ci-dessous montre comment vous assigner une texture sur une surface par un simple clic sur elle dans le panneau des textures.

Regardons de nouveau notre cabane de plus près:

L'entrée aurait besoin d'être modifiée, non?

Ce n'est pas qu'elle soit mal faite mais on a l'impression qu'elle a été mal construite. Bien entendu on pourrait tourner les textures pour que la jointure avec les murs soit parfaite. Le problème c'est que la texture semblera inclinée. Le mieux est de donner à l'entrée la même inclinaison que les murs.

Charger un nouveau bloc et ajuster le sur votre entrée pour qu'il le recouvre légèrement

Maintenant passez en mode "déplacement de bord" (edge move) [image] et assurez vous que votre direction de mouvement est bloquée en horizontal [image]. Puis glisser le bord inférieur vers le côté extérieur de la cabane afin de le rendre parallèle à lui. Ce sera plus facile à faire si vous rapprochez d'abord le bloc plus près de ce côté:

Ramenez-le de nouveau au milieu, donnez lui la même texture ( brownwood) et coupez le en utilisant Edit / CSG Subtract. Puis supprimez le bloc coupé et voilà! l'entrée est intégrée aux murs.

Pas tout à fait, les textures doivent encore être tournées.

Continuons, inclinons vers l'intérieur les 2 côtés de la planche de l'entrée (un angle de 5° est suffisant), Vous pourriez penser que cette partie haute rend moins bien que précédemment. Sélectionnez la partie, tournez la texture de 90° et déplacez la jusqu'à ce qu'elle concocrde avec la partie en dessous.Faites la même chose à l'intérieur. Nous n'avons pas besoin de faire la rotation des côtés.

Si vous voulez, vous pouvez le laisser comme cela. Pour ma part je préfère que notre toit dépasse à l'avant et à l'arrière.C'est un travail facile à faire:

Premièrement nous copions la partie au dessus de l'entrée, lui assignons la texture metalrivet2 et la plaçons n'importe où en l'air, dans un endroit où elle ne touche rien. Copiez la de nouveau, la deuxième copie sera notre outil pour faire la découpe dans la première, il nous servira donc d'emporte pièce. Déplacez, la deuxième partie pour qu'elle remplisse la première comme sur cette image puis découpez.

Vous n'aimez pas ces terminaisons?

Coupez les!

Copiez les restes et amenez les 2 à leur position définitive, une devant, l'autre à l'arrière. Vous noterez que les morceaux ne sont pas faits d'un seul bloc. Ce qui rend l'alignement des textures beaucoup plus difficile. Ne vous avis-je pas dit que c'était un travail facile?

Sachez le, toutes ces petits morceaux doivent être rendus individuellement et cela pénalise le taux d'affichage. C'est insignifiant pour notre petit niveau, mais sur un niveau plus compliqué il est bon de s'en souvenir et il faut donc réfléchir aux endroits où ils sont vraiment nécessaires.

Bien, notre cabane est à présent terminée. Avant d'ajouter plus de jolis détails vous pourriez avoir envie de finir votre entourage, j'ai utilisé wdwall_F1 que vous trouverez dans tutor.wad.

Fait? Génial, compilez et soyez ébahis!

Voilà, à présent vous connaissez presque tout au sujet des textures. Peut-être manque-t-il quelques arbres et rocher tout autour, et peut-être même que vous aimeriez être honoré avec une plaque commémorative?

Par la suite nous entrerons dans plus de détails artistiques pour notre niveau et parlerons d'une texturisation plus avancée.

précédent <<
>> suivant


WED Tutorial:Textures Finesses I

Textures - Davantage de Finesses - Partie I

Maintenant que notre niveau a un peu de gueule, il est temps pour nous de mettre une plaque commérorative à notre nom pour annoncer que nous sommes le créateur. Nous allons mettre une plaque avec notre nom et l'année de notre création.

Pour commencer nous avons besoin d'une texture appropriée. A moins que vous ne trouviez sur internet une plaque à votre nom, vous allez de voir la créer vous-même. Et vous allez devoir vous débrouiller par vous même car ce tutorial concerne le WED et en aucune manière un logiciel de dessin. Vous pouvez faire quelque chose de simple et de rapide dans le logiciel de dessin de votre choix, j'ai fait le mien avec photoshop, je l'ai nommé "anno" et je l'ai sauvegardé en tant que fichier .pcx dans mon répertoire de travail. Bien qu'il sera réduit d'environ la moitié dans WED plus tard, je lui ai donné une taille de 128X128. Il est plus facile de travailler sur cette taille que sur la taille définitive.

Si vous êtes prêt et que votre plaque attend dans votre répertoire de travail, ouvrez votre niveau dans WED et commencons. Vous pourriez cliquer sur Textures dans la fenêtre de projet, ouvrir le standard.wad et ajouter notre nouveau graphique de plaque. Encore mieux, vous pourriez créer votre propre fichier WAD pour y stocker vos propres textures. C'est ce que nous allons essayer.

Dans la barre d'icone cliquez sur Texture / Texture Manager ou clic droit sur n'importe quelle panneau WAD qui soit ouvert puis sélectionnez Texture Manager. Dans les deux cas la fenêtre suivante apparaît:

Vous voulez créer un nouveau WAD, aussi vous cliquez sur New WAD. Une fenêtre windows s'ouvre vous demandant le nom de votre nouveau fichier WAD. Tapez un nom et cliquez sur OK ou utilisez[Entrée].

Et à présent il est là, vous disposez de votre fichier WAD:

Si vous jetez un oeil sur votre gauche vous trouverez également une nouvelle barre avec le nom de votre WAD. Cliquez dessus et s'ouvrira une fenêtre. Elle est pour l'instant vide mais cela ne va pas durer.

Clc droit et choisissezAdd Texture, qui ouvrira votre répertoire de travail. Cliquez sur le graphique correspondant à la plaque portant votre nom et ajoutez le par un simple clic à votre WAD:

Nous avons besoin non seulement d'une texture mais également de la plaque elle-même. Ajouter un autre petit cube (Object / Add Cube / Small), déplacez le et retaillez-le jusqu'à ce qu'il soit à la bonne taille et à la place ou vous souhaitez pouvoir lire votre nom. Utilisez la grille pour vous aider.

Clic droit dessus et ouvrez sa fenêtre Properties (propriétés). Allez à Surface / Texture. Puis choisissez la face avant (qui devient en trait jaune) et assignez lui votre nouvelle texture:

En fait, ce n'est pas c'exactement ce que vous avez imaginé, n'est-ce pas ?

Pas de panique et au travail! Essayez d'abord de le réduire avec 0.5 et déplacez la texture avec les x- et y-offset le long de la face jusqu'à obtenir le bon ajustement. Si vous n'arrivez à rien de bien vous allez devoir expérimenter différentes valeurs pour le redimensionnement (scale) et les déplacements (offset) jusqu'à obtenir le bon résultat comme sur l'image ci-dessous:

Pour terminer donnez une texture aux autres faces.

Parfait!

- Je ferai bien un petit somme, moi !

précédent <<
>> suivant


WED Tutorial:Textures Finesses II

Textures - Davantage de Finesses - Partie II

Bien reposé ? Ok, alors nous allons pouvoir continuer et nous allons commencer par poser quelques pancartes.

Vu le temps que nous avons dépensé à la réalisation de notre niveau, nous ne voudrions pas que le premier individu qui passerait par là vienne piétiner notre niveau sans y être invité. Nous avons besoin d'une pancarte pour lui demander de passer son chemin. La meilleure façon pour procéder serait de faire un modèle. Mais cela est toujours préjudiciable en terme de taux d'affichage aussi nous allons essayer de trouver autre chose. Nous pourrions réaliser deux blocs, un pour le panneau et l'autre pour le baton, c'est la méthode utilisée pour notre plaque commémorative, aussi nous allons utiliser une autre méthode. La possibilité qu'il nous reste c'est l'utilisation d'un sprite. Les sprites sont un peu comme les textures sauf que nous ne devons pas les appliquer aux blocs mais nous devons simplement les placer n'importe où dans notre niveau.

Les sprites ne sont pas stockés dans un fichier WAD comme les autres textures. Tout ce que nous avons à faire c'est de le sauvegarder dans notre repertoire de travail. Les sprites sont faciles d'utilisation, prêt à l'usage et nécessite que très peu de mémoire. Alors vous vous dites :"comme c3'est, merveilleux!".Désormais je vais faire de nombreuses choses dans mon niveau sous forme de sprites!" Sauf que...les sprites sont plats comme des galettes, se tournent généralement en permanence vers le joueur et si ils sont fixex, montrent une image miroir sur leur dos. Vous voilà prévenu, nous pouvons continuer.

Ouvrez votre logiciel de dessin favori et dessinez un panneau d'avertissement attaché à un poteau. Pour optimiser le temps de rendu de votre niveau pensez, lorsque vous créer un sprite de toujours lui donner une dimension qui soit une puissance de 2! (2, 4, 8, 16, 32, 64, 128, etc). Pour le mien j'ai utilisé 128X256.

Bien entendu nous voulons que la partie de notre image autour du poteau soit invisible. Votre logiciel de dessin vous permet peut-être de déclarer certaines zones comme étant transparentes. Malheureusement si vous utimisez cette méthode vous serez déçu car ces zones apparaîtront en blanc lorsqu'elles seront utilisées par le moteur.

Heureusement notre moteur ignore le noir. Donc vous devez peindre en noir toutes les parties que vous souhaitez ne pas voir par la suite. Pour cela la valeur RVB (rouge, vert, bleu) doit être à zéro pour chaque composante. Le moteur ayant malgré tout une certaine tolérance et considère que vous voulez la transparence même avec des valeurs de 5 ou 6.

La pancarte est prête, sauvegardée comme fichier .pcx. Il est impatient d'être utilisé!

Retour dans WED, nous ouvrons notre niveau et avec Object / Add Sprite nous obtenons la liste de toutes les images sauvegardées dans notre répertoire de travail. Recherchez le nom de votre pancarte et chargez la dans votre niveau par un simple clic. Trop grosse? Redimensionnez-là jusqu'à obtenir la bonne dimension. En maintenant la touche [Ctrl] enfoncée vous déformez l'image proportionnellement.

Assurez vous que votre pancarte est bien ancrée dans le sol. Si vous complilez maintenant et que vous vous promeniez dans votre niveau vous allez voir votre pancarte à sa place. En tournant autour vous noterez que la pancarte tourne avec vous et que vous voyez toujours sa face avant. Cela pourrait être du à un mécanisme obligeant les pancartes à faire face en permanence aux intrus ! Où encore, vous pourriez tout simplement penser que ce procédé est idiot. Sélectionnez votre pancarte dans WED et ouvrez sa fenêtre de propriétés (properties). Allez à Position et donnez lui un angle dans n'importe laquelle des cases rotate (par exemple 0.01). A partir de maintenant votre pancarte gardera cet angle et ne fera plus face à la caméra.

Un angle minimal suffit mais si vous désirez que votre pancarte soit penchée vous pouvez la tourner davantage.

Parfait, maintenant vous pouvez compiler et vérifier que votre pancarte remplit bien son rôle dans notre niveau:

- Si nous commandions une pizza!

précédent <<
>> suivant


WED Tutorial:Textures Finesses III

Textures - Davantage de Finesses - Partie III

Quel douleur! Nous en avons bavé pour concevoir un niveau, et même pour mettre à la fin un panneau d'avertissement et voilà qu'un loubard vient d'écrire un graffiti sur le mur!:

Comment a-t-il fait cela?

Vous vous dites "Aucun problème," "juste peindre une texture .pcx, lui donner un fond noir et la placer contre le mur." Bien vu mais nous n'allons pas procéder comme cela.

Nous commençons par peindre sur un fond noir mais au lieu de le sauvegarder en .pcx nous allons lui donner un canal alpha et le sauver en tant que .tga.

Avec le format .pcx chaque pixel est affiché soit complètement opaque soit complètement transparent (donc invisible). Avec un canal alpha nous allons pouvoir déterminer une plage de transparence. Si nous dessinons notre graffiti avec un pinceau blanc en utilisant la fonction antialising notre dessin se fondra avec le fond sans à-coup (dégradé du blanc vers le noir qui est le principe de l'anti alising). Si vous sauvegardez une image avec l'anti alising en .pcx, vous verriez des bords foncés laids autour de votre dessin car tous les pixels non noirs sont montrés sans transparence. Avec un canal alpha, les couleurs les plus foncées sont affichées avec plus de transparence. Sauvegardez votre fichier en tant que .tga et posez le dans votre niveau pour voir la différence.

Tout d'abord dessinez Otto simplement en blanc sur fond noir. Pour obtenir plus de détails vous pouvez le faire à 2 fois sa taille définitive.

A présent assignez-lui un canal alpha:

Réduisez sa taille de moitié...

...et sauvegardez-le comme fichier .tga dans votre répertoire de travail:

Répétez la même opération avec le texte puis nous allons les mettre sur notre hutte.

Allez à Object/ Add Sprite pour récupérer les deux nouveaux fichiers .tga dans notre niveau (vous pourriez les avoir faits en tant qu'un sprite, mais rappelez-vous de garder la la règle de la puissance de deux ). Déplacez, tournez et redimenssionnez les sprites, puis posezles sur le mur. Faites en sorte qu'ils pénétrent légèrement sur le mur afin de ne pas donner l'impression qu'ils flottent.

Moi, Otto le terrible, j'ai laissé encore plus de graffiti..

- La pizza est arrivé!

précédent <<
>> suivant


WED Tutorial:Textures Finesses IV

Textures - Davantage de Finesses - Partie IV

Ne vous avais-je pas promis des arbres dans cette section?

Oui, alors nous allons planter quelques arbres dans notre niveau. Une fois encore vous pourriez utiliser un modèle consommant de la mémoire et du taux d'affichage mais puisque nous sommes si doués avec les sprites continuons dans cette voie. Vous pourriez protester endisant qu'un sprite plat comme une gaufrette ne pourra jamais donner l'illusion d'un arbre! Oui mais nous allons utiliser un truc, nous allons les croiser!

Quel est le meilleur format, .pcx or .tga? Ce n'est pas vraiment une question. .tga bien entendu! Saisissez votre appareil photo numérique et prenez une photo de l'arbre dans le jardin de votre voisin. Avec l'aide des dernières technologies, convertissez-le en un fichier .tga.

Chargez vos 2 sprites dans votre niveau, comme nous l'avons fait pour le graffiti - que vous aurez pris soin de sauvegarder dans votre répertoire de travail bien entendu.:

Sélectionnez-les [image] et groupez les comme nous l'avons déjà fait en utilisant Object / Group / Finish. Maintenant ajustez la valeur de rotation dans les propriétés comme nous avons fait avec la pancarte ou le graffiti pour le maintenir en place.

Votre arbre a-t-il un drôle d'air?

Oui il donne l'impression d'être flou. En utilisant un fichier .pcx à la place d'un fichier .tga il s'afficherait correctement mais nous aurions de nouveau ces bords foncés laids.

Alors que faire, utiliser un fichier .tga et avoir du flou ou un fichier .pcx et avoir des bords noirs?

Le moteur ne trie pas ces 2 types de fichiers de la même façon:

Comme nous le savons, les pixels dnon transparents d'un fichier .pcx peuvent être montrés ou pas. L'ordre dans lequel ils sont montrés est déterminé par leur distance par rapport à la caméra. Si le joueur se tient devant n'importe quel sprite .pcx dans le paysage, tout ce qui se trouve derrière les pixels qui ne sont pas complètement noirs est couvert. Ceci vient des bords qui ne sont pas tout à fait noirs :

Le moteur pose les objets transparents selon les distances de leur centre à la caméra. Quand la caméra fait face à deux sprites transparents, elle voit le sprite le plus près dans sa totalité à l'avant. La partie du sprite qui se trouve derrière sera également complètement rendu. Ce qui donne quelque chose d'erroné lorsque les 2 sprites se croisent dans l'éditeur de niveau:

Note: la même chose se produit lorsqu'on utilise le drapeau transparent.

Vous voulez les deux! Une texture .tga semi-transparente et un affichage correct de notre arbre sans les bords sombres!

OK, nous pouvons le faire. Nous pouvons résoudre ce problème en coupant le sprite en deux et en utilisant 4 moitiés posées en croix pour faire notre arbre.

la partie gauche et [image] droite de l'arbre...

... sont maintenant placés en vis-à-vis, groupés, copiés, tournés et croisés (ou vous pouvez charger chaque sprite individuellement). Si vous le voulez parfaitement symétrique, utilisez uniquement une moitié de l'arbre, copiez-le quatre fois et placez-les une croix. Cependant, cela ne paraîtra pas très réaliste.

Rappelez-vous d'ajuster légèrement les valeurs de rotation dans le panneau de propriétés ou les sprites continueront à faire face à la caméra

Jetons un oeil à notre arbre dans le niveau:

Maintenant votre arbre s'affiche correctement!

Bien entendu nous ne voulons pas un arbre de bandes dessinées course. J'ai utilisé cet arbre à titre d'illustration. Utilisez votre propre fichier .tga d'un arbre que vous aurez photographié ou troué sur le net. Vous le trouverez tout aussi merveilleux!

- Si nous buvions une bière!

précédent <<
>> suivant


WED Tutorial:Textures Finesses V

Textures - Davantage de Finesses - Partie V

Votre arbre n'est pas mal, le feuillage rend bien mais le tronc pourrait être un peu plus vigoureux et pourquoi ne jette-t-il pas d'ombre? Simplement parce que les sprites ne génère pas d'ombre. Que devons-nous faire alors? Utiliser un modèle ? Si l'arbre jouait un rôle important dans notre niveau nous pourrions utiliser un modèle. Il y a cependant un compromis qui corrige le manque d'ombre et rend le tronc plus vigoureux.

Nous fabriquerons notre tronc à partir de blocs. Cela nous fournira une ombre et donnera à l'arbre un aspect plus vigoureux.

Tout d'abord nous retournons à notre image de l'arbre et effaçons le tronc. Souvenez-vous que vous devez donner à toute votre image des dimensions qui soient une puissance de 2 (comme 256X256, par exemple). Maintenant nous allons créer le tronc.

Les troncs d'arbre sont très rarement symétriques. Nous devrons donc employer au moins deux blocs différents pour réaliser ceci (ici j'emploie une pyramide et une colonne). Vous trouverez une texture appelée bark (écorce) dans standard.wad. l'écorce dans standard.wad. Cette texture pourrait sembler meilleure si vous la redimensionnez à 0.5/ 0.5 :

Dés que le tronc sera à sa place nous lui ajouterons la cime d'arbre faites des sprites .tga coupés de moitié:

Si vous essayez de redimensionner votre cime d'arbre lorsqu'elle est regroupée (ou la totalité de l'arbre) vous noterez que les sprites perdent leur alignement:

Les sprites doivent être redimensionnés individuellement et il est préférable de les redimensionner avant de les placer en position.

Inclinez un peu la cime d'arbre pour lui donner plus de réalisme :

Maintenant notre arbre jette une ombre !

Nous allons mettre quelques pierres dans notre niveau:

Chargez un cube ou, ce qui est encore meilleur, une primitive dans votre niveau. Comme tout le monde le sait, les pierres sont des choses curieusement formées. Nous pouvons tordre la forme de notre primitive en déplaçant ses bords et sommets jusqu'à ce qu'elle ressemble à un rocher. Rappelez-vous de ne pas générer ces blocs concaves embêtants !!

Déplacez votre objet quelque part où rien n'obstruera votre vue et utilisez ces boutons [image] pour vous aider un aspect rugueux à votre roche:

Rappelez-vous, ce sera beaucoup plus facile si vous utilisez [image] et [image]. Les plus faciles à déformer sont les pyramides à 3 côtés, mais de simples sphères peuvent également être transformées avec un peu de patience. Une fois que vous êtes content de la forme de votre roche, assignez-lui une texture appropriée et bien dimensionnée. (j'utilise rockywall). A partir d'une roche vous pouvez créer plusieurs variations de votre rocher en le copiant puis en le modifiant.

Amusez vous à en fabriquer et positionnez les dans votre niveau qui finalement pourrait ressembler à ceci:

Vous êtes maintenant un expert en matière de texture et nous pouvons passer à autre chose.

Maintenant vous aimeriez avoir une porte car vous êtes malade d'être un fantôme désincarné !

Ok, le prochain chapitre vous montre comment faire une porte qui s'ouvre et se ferme. Super, vous obtiendrez un corps !

précédent <<
>> suivant


WED Tutorial:Open Door I

Ouvrir la porte- Partie I

Jusqu'à présent, notre niveau a été complètement statique. Il est temps d'y mettre un peu de mouvement. Nous démarrerons avec une porte. Le premièr endroit qui nous vient à l'esprit pour mettre une porte, c'est l'entrée de la maison. malheureusement, cet endroit, comme nous le verrons plus tard n'est pas fait pour recevoir une porte. C'est pourquoi nous mettrons notre porte dans un des murs dlatéraux.

Notre porte doit être une entité de carte, que nous chargeons dans notre niveau et y attachons un script prédéfini. En outre, puisque le niveau doit avoir une entité joueur avant que l'autre élément soient mis en action, nous allons inclure un de ces derniers également..

Commençons la porte avec Object / Load Prefab (ou Add Prefab, si vous l'avez stocké là).Chargez votre bloc de poinçon du premier chapitre que vous aviez utiliser pour faire le trou dans le mur, qui, suivant mon bon conseil, vous avez sauvegardé. Déplacez le bloc à où vous voulez que votre nouvelle entrée latérale soit et agrandissez-la en utilisant [ Ctrl ] + [image] (ceci conserve les proportions). Puis faites le un peu plus large afin qu'il soit assez gros pour coller au mur. Donnez lui la même texture que le mur. Maintenant pour le plaisir, Edit / CSG Subtract. Attention: prenez garde que votre bloc ne soit pas trop bas afin que vous n'entamiez pas le plancher avec votre poinçon, vous vous en apercevrez si vous voyez apparaître des lignes là ou le plancher a été découpé. Si c'est le cas, cliquez sur Undo et essayez de nouveau après avoir remonté le bloc légèrement (pas trop haut malgré tout pour que vous n'ayez pas à sauter par dessus le seuil).

Si vous n'aviez pas sauvegardé le bloc de poinçon voici comment procéder :

Sélectionnez le hangar, niveau hiérarchique bas et choisissez le grand mur arrière. Copiez-le, niveau hiérarchique haut [image] et séparez la copie par Object / Group / ungroup du reste de votre hutte. Maintenant, déplacez-la à l'endroit où vous voulez que la nouvelle entrée soit. Redimensionnez-le et texturez-le convenablement et poinçonnez votre trou. Et par pitié, cette fois pensez à sauvegardez votre poinçon en utilisant Object / Save Prefab! mais comme nous en avons encore besoin surtout ne l'effacez pas. Placez le quelque part dans un espace ouvert dans votre niveau.

Naturellement, vous l'avez deviné, nous avez besoin toujours de la porte elle-même. Mais ce n'est pas la seule chose. Allez voir votre porte, grattez-vous la tête et alors vous comprendrez ce qui nous manque ; nous avons besoin également d'un cadre de porte. Aussi maintenant vous chargez une nouvelle copie de votre préfabriqué fait maison (une fois encore si vous ne l'aviez pas sauvegardé, vous êtes un cas désespéré!). Avant que ce préfabriqué devienne une porte, nous l'utiliserons pour la menuiserie de notre bloc flottant que nous avons mis de côté pour la transformer en cadre de porte.

Avant tout, vous devez assigner la même texture aux deux blocs (j'utilise wooddark). Maintenant mettez les blocs l'un sur l'autre et agrandissez légèrement le premier.

Maintenant élargissez le plus petit afin qu'il colle parfaitement au plus grand en utilisant [image] (pour être sur de ne pas l'agrandir en hauteur par inadvertance):

Puis coupez !

Notre cadre résultant n'est pas un simple bloc mais il est composé de nombreux petits blocs. Sélectionnez-les en traçant un cadre [image] avec la souris autour d'eux, puis groupez-les avec Object / Group / Finish. Maintenant nous plaçons notre cadre où il doit se trouver et puisqu'il n'est magré tout pas parfait nous utilison sla fonction niveau hiérarchique bas puis nous tournons les textures jusqu'à ce qu'elles soient assorties.

J'ai effacé la partie basse du mien. C'est tout simplement comme ça que je l'aime. Ca maintien également le seuil inférieur. Si vous voulez faire de même, vous devez juste dégrouper le cadre , Object / Group / ungroup, et effacer la partie basse. Vous pourriez également redimensionner le seuil pour le rendre plus étroit ou mettre un bloc comme une marche devant votre entrée, en clair vous ke faites comme vous le sentez.

Bien, maintenant il est temps de mettre la porte sur ses gonds ! Pour cela déplacez le deuxième bloc que vous avez utilisé comme poinçon dans le cadre de la porte et redimensionnez-le de nouveau jusqu'à ce qu'il ressemble à une porte qui s'adapte parfaitement dans son cadre. Vous pourriez préférer le charger de nouveau dans votre niveau, c'est également très bien.

Bien maintenant que vous avez la porte, comment comptez-vous la faire fonctionner ?

Pour mettre notre porte en mouvement nous avons besoin qu'elle soit une entité. Une entité carte dans notre cas. Tout d'abord il faut sauvegarder votre bloc :Object / Save Prefab .

Maintenant nous ouvrons une nouvelle carte (File / New) et chargeons notre porte avec Object / Load Prefab. Normalement les portes s'ouvrent par l'oscillation autour d'un point d'appui. Pour éviter de programmer, nous avons l'intention d'assigner une action préfabriquée à notre porte. Quelqu'un d'autre a fait la programmation et a fixé le point d'appui juste au centre.

Aussi si notre porte est exactement placé au centre de la carte, elle tournera autour de son axe central :

Ce n'est pas vraiment d'une telle ouverture que nous rêvions pour notre porte.

La plupart des portes sont accrochées d'un côté. Déplacez la porte pour que le point de pivot soit placé d'un côté de la porte. L'idéal étant de placer l'axe des Y sur le bord de la porte et l'axe des x au milieu de l'épaisseur de la porte.

Notre porte nécessite une meilleure texture. L'idéal serait d'utiliser de nouveau standard.wad. Si vous êtes devenu un as des texures grâce à nos chapitres précédents vous pouvez bien entendu créer votre propre texture! Vous pouvez attacher n'importe quelle texture (se trouvant dans un WAD) à votre entité de carte.

En ce qui me concerne j'utilise woodmetal. Une fois encore nous devons aligner parfaitement notre texture comme nous l'avons appris.

Jouez avec le redimensionnement (scale) x et y afin que la texure recouvre la porte puis jouez avec x- et y-offset jusqu'à obtenir un bon résultat:

La seule chose qui nous manque à présent, c'est une poignée. Nous allons donc en construire une en utilisant un bois de charpente (lumber) et une sphere par exempleque vous redimensionnez et assemblez ensemble:

Pour terminer nous compilons notre niveau de porte en tant que Entity Map!:

Hé, super, vous venez de réaliser votre première entité de carte!

Maintenant sauvegardez votre porte (File / Save As) sous un nom créatif dans votre répertoire de travail:

- Café!

précédent <<
>> suivant


WED Tutorial:Open Door II

Ouvrir la porte- Partie II

Ah, un café fait parfois des merveilles!

Vous avez bien sauvegardé la porte?

Après que vous ayez sauvegardé votre porte (et non avant) ouvrez votre niveau principal. Allez à Object / Add Map-Entity et sélectionnez votre porte à partir de la liste qui s'ouvre. Son nom est à présent assorti de l'extension .wmb. Positionnez-là à sa place et clic droit pour ouvrir sa fenêtre de propriétés.

Là où nous trouvions auparavant un onglet surface, nous avons à présent un onglet "behavior" (comportement). Dans le champ correspondant à Action vous pouvez voir "ndef." Qui signifie "not defined." ou "nn définie". Nous allons changer cela à présent.

Les actions sont des programmes, et ont besoin d'avoir été crées par un script dans un langage que le moteur comprend (c-script) et être capable de les transformer en actions, le moteur ayant besoin de lire ces scripts. Ce qui signifie qu'avant de donner une action à notre porte, notre niveau à besoin de son propre script.

OK, donnons donc au moteur ce dont il a besoin. Pas d'inquiétude ce script se débrouillera sans nous. Si vous savez lire, vous saurez le faire fonctionner.

Allez à File / Map Properties. Sous Main dans la zone correspondant à "Script", vous trouvez "ndef". Cliquez simplement sur l'icône du milieu (New Script) et WED créera un fichier script par lui même et sous le nom de votre niveau mais avec l'extension .wdl. Il sauve également ce fichier dans votre répertoire de travail. Bien pratique n'est-ce pas ? Avec le X sur la droite vous pouvez supprimer le script en question et avec l'icone à gauche vous voyez tous les fichiers .wdl qui sont stockés dans votre répertoire de travail afin que vous puissiez en choisir une.

Ok, à présent le moteur a un script, nous allons donc pouvoir avancer et donner une action à notre porte.

Fermez la fenêtre et revenons à la porte:

Cliquez sur la porte, ouvrez la fenêtre de propriétés (properties), puis cliquez sur l'onglet behavior. Maintenant cliquez sur l'icone "fichier" et il fera apparaître une liste de toutes les actions disponibles. Cliquez sur celle qui porte le nom de "door" (porte) et votre porte sera comment se comporter:

Du calme, ne compliez pas de suite ! D'abord nous devons inclure une entité joueur dans notre niveau. Si nous ne le faisions pas le moteur pensera que nous ayons vraiment besoin de faire fonctionner la porte et ne fera donc rien.

Avant tout, nous avons besoin d'un personnage pour notre joueur. Par Object / Add Model nous sélectionnons guard.mdl. Placez d'abord ce type devant notre porte et redimensionnez le jusqu'à ce que ses proportions correspondent à celles du niveau (qu'il passe dans la porte par exemple) puis puisqu'il n'est pas nécessaire que la position initiale de notre joueur soit devant une porte nous le plaçons à l'extérieur de notre hutte, debout sur le sol.

- Il faut que ses pieds pénètrent légèrement dans le sol:

Si vous compilez et démarrez votre niveau maintenant, vous verrez un garde médévial faisant de drôles d'exercices. Cependant votre porte ne s'ouvrira pas. Pour arrêter le comportement étrange du garde et pour que nous en prenions le contrôle, il est nécessaire de li assigner également une action.

Allez dans la fenêtre des propriétés du garde et sélectionnez lui comme comportement "player_walk_fight." Assurez-vous qu'il n'y ait qu'une seule entité qui utilise cette action dans le niveau, sinon l'une sera coincée pendant que l'autre se déplacer sous votre contrôle.

Terminé ? Bien alors vous pouvez compiler!

Vous l'avez fait et pourtant vous êtes déçu car votre garde fait toujours ses exercices et votre porte ne s'ouvre toujours pas?

Dans ce cas c'est que vous êtes en mode preview et les actions sont ignorées par le moteur. Démarrez votre niveau avec File / Run Level ou cliquez sur [image]. Ouaip, ça y est, maintenant vous avec un corps que vous pouvez contrôler. Vous vous balancez pendant que vous marchez, vous entendez vos bruits de pas...!

Et à présent si vous voulez entrer dans la maison, placez vous devant la porte fermée et pressez la touche [Espace].

Vous pouvez fermer la porte de la même façon. [Espace] = ouvrir, [Espace] = fermer, [Espace] = ouvrir etc. Amusez-vous!

Génial!

Pendant que vous regardez la porte s'ouvrir et se fermer je dois vous dire aurevoir. Ce tutorial est etrminé à présent mais il sera continué par quelqu'un d'autre.

- On a bien mérité de boire un coup et de trinquer!

précédent <<